[PlanetCCRMA] dssi plugin gui problem

Steve Harris S.W.Harris@ecs.soton.ac.uk
Mon Jul 3 08:05:04 2006

On Mon, Jul 03, 2006 at 10:56:12 -0400, Nate figlar wrote:
> >Which kernel are you running ("uname -a")?
> I am running the preempt or known as "edge" kernel however I also
> tried the standard stock fedora kernel and still had the same problem
> >
> >What do you see when you run "strace fluidsynth-dssi"?
> OK now for the strange part. I did this command in the preempt kernel
> and now it runs fine. the gui came right up. even after that it comes
> right up from the gui ccrma menu in gnome. I did some googling earlier
> on this and with a user in an agnula forum experienced the same thing
> and it mysteriously fixed itself too. There was another post I found
> on a chached page in google from the old rosegarden mail list however
> it wouldn't let me see the old replies. from what I can see it looks
> like some sort of bug in fluidsynth-dssi being it doesn't seem to
> kernel dependent or even distro dependent. I will be sure to post
> agian if it reoccurs and let you all know what the output of the
> "strace fluidsynth-dssi" brings up.

If you do it without strace does it still fail? If so, it's probably a
race condition (ie. two things that shouldn't happen at the same time do),
this can happen, and is often "fixed" when you run something that changes
the timing, like strace.

The bad news is that they are notoriously hard to fix :( Not impossible

- Steve