[PlanetCCRMA] VST on Fedora Core 4?

Timo Sivula timo.sivula@gmail.com
Sun Feb 12 06:29:02 2006


I just recently upgraded from FC1 to FC4. I have to HDD:s on my PC, one
used to run FC1 but is now FC4. The other is still using FC3. The edge
kernel works fine and Fedora Core 4 seems nice.

However, I have trouble getting my VSTs working right. After the
upgrade, jack_fst compiled under FC1 still starts nicely and loads my
B4.DLL without problems. B4 can be played, but giving it any kind of
program change messages either from my keyboard or Rosegarden crashes
it. I tried to start from scratch according to my FC3 VST howto:

I get stuck when trying to compile the fst library:

[04:27 PM] el:/usr/local/src/fst-1.6$ make
make[1]: Entering directory `/usr/local/src/fst-1.6/fst'
LD_LIBRARY_PATH=":$LD_LIBRARY_PATH" /usr/bin/winebuild -fPIC -o
libfst.spec.c --exe libfst -mgui   pthread.o interlocked.o gettid.o
libwinelib.o vstwin.o fstinfofile.o fst.o   -L/usr/lib/wine
-L/usr/lib/wine  -ladvapi32 -lcomdlg32 -lgdi32 -lkernel32 -lodbc32
-lole32 -loleaut32 -lshell32 -luser32 -lwinspool
winebuild: executable must be named via the -F option
make[1]: *** [libfst.spec.c] Error 1
make[1]: Leaving directory `/usr/local/src/fst-1.6/fst'
make: *** [fst] Error 2
[04:27 PM] el:/usr/local/src/fst-1.6$

Has anyone tried my VST howto on FC4 and had success? Any ideas what
might be wrong here. I would appreciate any help to upgrade the HOWTO to

br, Timo