[PlanetCCRMA] Jack and KDE

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Wed Apr 26 12:14:01 2006

On Wed, 2006-04-26 at 20:01 +0200, Nigel Henry wrote:
> On Wednesday 26 April 2006 18:13, Fernando Lopez-Lezcano wrote:
> > On Wed, 2006-04-26 at 09:20 -0400, Roy Vestal wrote:
> > > I'm getting an error starting Jack in my KDE environment. This is a new
> > > install/build of FC3 and I'm wondering if ARTS is turned on. I'm
> > > assuming this would be the cause of my Jack start errors. I believe the
> > > error is "jackd could not start hw:0 in use". At the time of this
> > > writing I am not able to get to the machine for the exact error.
> > >
> > > My question: Can ARTS be active and jackd still work or does it need to
> > > be off? I'm assuming off is the correct answer at this time.
> >
> > Jack normally takes complete ownership of the sound card, all other
> > programs that use it have to be "off".
> Hi Fernando. I've just tried to recreate this problem on 2 different machines 
> running FC3. The Arts sound server is running, I ran a live audio stream from 
> bbc.co.uk, using embedded realplayer in Firefox, and played a cd through KsCD 
> at the same time, and jackd started through qjackctl with no error messages. 
> That was with both the vanilla kernel-2.6.9-1.667 (with realtime unchecked, 
> otherwise you get an unrelated error message) , and with 
> kernel-2.6.11-0.3.rdt.rhfc3.ccrma.

Which soundcard?

> With FC2 , and on the machine with Audigy2 soundblaster (emu10k1) there are no 
> problems. I can have the Arts server started, run a live audio stream, and 
> jackd will start with no errors. On the other machine with the Ensoniq 
> (ens1371), If I have a live audio stream running, jackd won't start, with the 
> hw0 is in use error. Likewise if I have the Arts server running.
> This is sort of sounding like a sound card problem with certain distro's. FC3 
> is ok, both with Audigy2 soundblaster (emu10k1), and Ensoniq (ens1371), but, 
> FC2 gives no errors with the machine with Audigy2 soundblaster, but gives 
> jackd errors (hw0 in use) on the machine with Ensoniq card.

That last one makes sense, the Audigy2 can play multiple streams
simultaneously _in hardware_ (so you can "open" it multiple times). The
Ensoniq can't. 

-- Fernando

> Roy. What is the soundcard on your machine?
> My machines:
> I-friend 1.3Ghz celeron, 1GB RAM, Audigy2 soundblaster sound card.
> Gateway 500, pentium 3 katmai, 256MB RAM, Ensoniq sound card (ens1371).
> Just another spanner in the works. Nigel.