[PlanetCCRMA] qjackctl/jackd acting differently?

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Sun Sep 18 17:31:02 2005

On Fri, 2005-09-16 at 10:45 -0700, bernie@vcn.bc.ca wrote:
> hi everybody,
> after months of lurking on this list and happily pecking away at learning
> my planet ccrma setup, i've worked up the courage to try and ask for help.
> i'm noticing funny behavior trying to get jack to operate in realtime.
> first specs:
> fujitsu s2020 laptop
> athlon xp-m 2100+ (1.4GHz)
> 768MB ram
> running FC3 w/CCRMA
> trying both kernels 2.6.10-2.1.ll.rhfc3.ccrma and 2.6.11-0.3.rdt.rhfc3.ccrma
> (same trouble with either kernel)
> next the (current) problem:
> when starting jack from qjackctl, i get:
> 10:28:46.977 /usr/bin/jackd -R -dalsa -dhw:0 -r48000 -p256 -n3 -S
> 10:28:46.985 JACK was started with PID=5827 (0x16c3).
> cannot write to jackstart sync pipe 4 (Bad file descriptor)
> jackd: wait for startup process exit failed
> jackd 0.99.36
> Copyright 2001-2003 Paul Davis and others.
> (etc. etc.)
> it starts after that but no "RT" light in the qjackctl window. 

Hmmm, with the newer kernels you no longer need to use "jackstart" to
start jack. Try replacing the command in qjackctl with just "jackd"

-- Fernando

> however,
> when starting it from command line (same command), i get no "cannot write
> to jackstart..." message, but from command line i don't know how to check
> if jack is running realitme.  either way i get a few xruns a minute
> without any real activity, and if i run, say alsaplayer through jack i get
> thousands of xruns constantly (and very often distorted sound, but i think
> that may have to do with 48k/44.1kHz discrepancy and maybe the period
> size?)
> i've checked to see that the rtload init.d ran:
> [root@localhost audio]# /etc/rc.d/init.d/rtload status
> Realtime kernel module is loaded, current parameters are:
>  any=1; gid=-1; mlock=1
> [root@localhost audio]# /sbin/lsmod | grep realtime
> realtime                5128  0
> commoncap               8064  1 realtime
> [root@localhost audio]# /sbin/chkconfig --list rtload
> rtload          0:off   1:off   2:on    3:on    4:on    5:on    6:off
> (this is me as root, but the jack calls were done as normal user)
> is that what it should look like?
> i spent the better part of last night googling the problem, and found bits
> and pieces, but no clear idea of what to do next.  thanks in advance for
> any help, please tell me if i should post any other info...
> bernie arai
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA@ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma