[PlanetCCRMA] apt-get dist-upgrade prob on FC3

nigel henry cave.dnb@tiscali.fr
Sat Sep 17 10:07:01 2005

On Saturday 17 Sep 2005 1:33 pm, nigel henry wrote:
> I've installed the key, and apt-0.5.15cnc6-3.rhfc3.ccrma. Then ran apt-get
> update, and apt-get dist-upgrade. 795MB on dial-up later, there are
> problems installing the updates, and planet kernels.  See below.
> Committing changes...
> Preparing...                ###########################################
> [100%] installing package kdeutils-3.4.2-0.fc3.1 needs 592KB on the /
> filesystem
>         installing package kernel-utils-2.4-13.1.49_FC3 needs 808KB on the
> / filesystem
>         installing package libpng10-devel-1.0.18-1.fc3 needs 808KB on the /
> filesystem
>         installing package libpng10-1.0.18-1.fc3 needs 2MB on the /
> filesystem installing package man-1.5o1-7 needs 1008KB on the / filesystem
> installing package mgetty-1.1.31-4_FC3 needs 2MB on the / filesystem
> installing package mikmod-3.1.6-31.FC3 needs 2MB on the / filesystem
> <snip> very long list!
> installing package vim-common-6.3.086-0.fc3.1 needs 165MB on the /
> filesystem installing package words-3.0-2.3 needs 165MB on the / filesystem
> installing package xcdroast-0.98a15-8 needs 168MB on the / filesystem
> installing package xloadimage-4.1-34.FC3 needs 168MB on the / filesystem
>         installing package xorg-x11-font-utils-6.8.2-1.FC3.13 needs 168MB
> on the / filesystem
>         installing package xorg-x11-tools-6.8.2-1.FC3.13 needs 168MB on the
> / filesystem
>         installing package xorg-x11-twm-6.8.2-1.FC3.13 needs 168MB on the /
> filesystem
> E: Error while running transaction
> Strangely some of the updates, fonts 75dpi, and fonts 100dpi  for instance,
> don't show up on this list.
> I've only installed apt from planetccrma manually before on FC1 and FC2, so
> am not sure about what has turned up in /etc/apt. I have sources.list.d (a
> directory). As stated the only uncommented list is the planet one. I have
> an apt.conf file in /etc/apt, but also another config file in a directory
> apt.conf.d and this file is named, planetccrma.conf. Might I be seeing a
> conflict between these 2 apt.conf files?
> The / and /home partitions are really too small for FC3. Mandrake 10.0 had
> been on these before, and having spent nearly 5 days on dialup DLing the
> iso's, I wanted to give FC3 a go. There is 652.7MB of 5.4GB still free, and
> with under 300MB of extra disk space taken up when the updates are
> installed, I should still be within 5% of max in the / partition. Any
> suggestions appreciated.
> Sorry for this not being strictly music. Nigel.

Hi Again. This has gone from weird to very weird. Having nothing better to do 
I put the apt.conf file in an obscure directory for safe keeping. Still no 
change when running apt-get dist-upgrade. Then tried apt-get upgrade. Well 
this went ok, now telling me that I needed 262MB of updates. Apt-get 
dist-upgrade had wanted to remove libtool, and was holding back kdevelop. I 
went for the option on apt-get upgrade, which then DL'd 14.4MB of kdevelop, 
and then proceeded to install all the 262 updates. Methinks, right go for the 
apt-get dist-upgrade again. Right there's a few packages left to install as 
below, and now it wants to remove kdevelop that I've just installed, also it 
wants to remove libtool, but I knew that. 

Rest of the stuff for apt-get dist-upgrade.
New upgrades:
New installs:

Right. Go for it. Now apt-get dist-upgrade runs ok and installs the rest of 
the packages, boots out my just installed kdevelop (that took an hour on 
dial-up to DL) and also removes libtool. 

Incidentally, during the apt-get upgrade installs, perhaps for the first 40 or 
so, KDE kept playing the KDE start up .wav in a variety of versions. Now. I 
havn't even got this set up to play! Also about 10 minutes or so after the 
update install had finished, while I was away taking a whizz, I heard FC3 
playing my twilight zone intro that I have set up to play when gdm starts. 
This seems to indicate that FC3 truly is in the twilight zone.

Just as a side issue. Obviously Ineed to install FC3 on partitions with a bit 
more space. I'm now down to 340.6MB free space 93.8% full on the / partition. 
Can I save /var/cache/apt/archives to another drive, and then when I find 
more space for a new install of FC3, overwrite the new 
/var/cache/apt/archives with my saved one?  If i then run apt-get update, and 
then apt-get upgrade, will apt detect the already downloaded packages in 
/var/cache/apt/archives? Bear in mind that I'm playing the violin while 
typing this. You know 795MB of DL's on dialup ain't no fun. I'd have thought 
that the iso's on http://iso.linuxquestions.org would have been a bit more up 
to date, but that's life. Nigel. Giving a bit of Saturday afternoon (in 
France that is ) entertainment, and now once more entering the twilight zone 
to DL some music apps from planetccrma.
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA@ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma