[PlanetCCRMA] Newbie basic questions on PlanetCCRMA installation

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Thu Nov 10 14:30:02 2005

On Tue, 2005-11-08 at 15:55 +0200, Mikko Harjula wrote:
> I didn't see PlanetCCRMA for AMD 64-bit architecture so I installed
> the apt-enabled 32-bit FC3 from the PlanetCCRMA site and PlanetCCRMA
> on top.  Is this the way to go or can the PlanetCCRMA stuff be
> installed on top of AMD 64-bit FC3? ... OK found from mailing list
> archives that the AMD 64-bit is not there so my guess was correct.
> Maybe this could be mentioned somewhere?

I'll put a note in the main page, as you say that should be mentioned up
front. Sorry. I'm getting more and more "does it run on x86_64"
questions. At some point I'd like that have that available but I don't
expect to see any big performance improvements over plain 32 bit Fedora.
There are somw downsides in the sense that I think that things like
binary codecs for video playback and some extensions for Mozilla/Firefox
don't work on 64 bit systems. 

> I got the red (redhat) update button glowing in the KDE panel asking
> me to update the system but I have been updating with apt only as I
> imagine yum update from FC3 repositories would overwrite CCRMA stuff
> and break the apt bookkeeping.  Is this the case?  Can I get FC3
> updates from CCRMA apt repository?

You can use both (ie: the redhat updater/yum and apt), but not both at
the same time, of course :-) They both depend on the normal rpm
databases that are always there. The Fedora updates are included in the
Planet CCRMA apt repositories but usually with some delay with respect
to the "official" releases (I try to test them out before upgrading). 

> "apt-get install mplayer" complained that "mplyer not found".  What
> repositories should I use to locate this?

You could try freshrpms. 

What I usually do for additional packages is to enable any extra
repositories, install only the packages that I need and then disable
them. That's because I don't have the time to test for compatibility
with other packagers all the time. 

> I cannot connect to other hosts with ssh.  It just hangs till timeout.
> However I can connect into this host from another Linux box.  I tried
> to use ethereal to see what goes on but I cannot find ethereal binary
> although ethereal package is installed.  So is there a way to query
> apt repositories like: "in which packege can I find file
> '^.*/bin/ethereal$'" or "list all packages whose description contains
> regexp '(note|notation) editor'"?

The symptom suggests to me some problem with DNS (Domain Name Servers) -
that is, the service that maps ip numbers to host names (and viceversa).
Can you ping the other host you are trying to connect to? Can you see
the ssh port on the destination host? (you could use nmap, "apt-get
install nmap" to install). Do you see anything in the logs of the
destination host if you have access to them?

> I haven't used SELinux before and reading from the CCRMA mailing list
> archive I found someone trying to disable SELinux.  I already tried to
> disable it temporarily (and it didn't solve the ssh problem) but in
> general should I disable SELinux completely or does all CCRMA stuff
> run well with FC3 SELinux?

It should work fine with Selinux enabled (AFAIK). 

I had to disable it while working with a newer kernel I'm testing but
not with the regular ones that are currently available. 

-- Fernando