[PlanetCCRMA] FC3, ALSA and Noteedit; scheduler issue

Nick Metrowsky nmetro@frii.com
Mon May 16 14:28:01 2005

Hi Fernando,

Thank you for writing. I tried what you suggested and it still does not 
work. This is a not a big issue, so I can wait until you can resolve the 
tse3 issue.

Take care!


Fernando Lopez-Lezcano wrote:
> On Sat, 2005-05-14 at 11:18, Fernando Lopez-Lezcano wrote:
>>On Sat, 2005-05-14 at 10:58, Nick Metrowsky wrote:
>>>Hi Folks,
>>>I am running FC3 and I installed everything from the FC3 CDs, as well 
>>>as, Planet CCRMA. I am running the stock FC3 kernel, because my laptop 
>>>internal wireless requires ndiswrapper, which is not happy with the 
>>>Planet CCRMA low-level kernel. Under either kernel, I still have the 
>>>same problem I am about to describe.
>>>When I start up noteedit, and some other applications, I get the 
>>>following error:
>>>kbuildsycoca running...
>>>Reusing existing ksycoca
>>>LilyPond check: found version: 2.4.5
>>>WITHOUT semicolons.
>>>WITH wavelines (for trills)
>>>WITH slures in graces
>>>NOTE LENGTHs after chords
>>>"\property" keyword does not exist
>>>cannot create an ALSA MIDI Scheduler
>>>cannot create an OSS MIDI Scheduler
>>>error opening Midi Device --> music cannot be played
>>>TSE3 Copyright information :(c) Pete Goodliffe, 2000-2002. A Trax 
>>>Software Product. Version: 0.2.7
>>>QCheckBox::setProperty( "Checked", value ) failed: property invalid, 
>>>read-only or does not exist
>>>I have tried changing the noteedit configuration, and whatever I try I 
>>>still get a message stating that it cannot create a scheduler OSS or ALSA.
>>It looks like the alsa sequencer module may not be up and running
>>(search for it with "/sbin/ldmod|grep snd-seq"). 
> Noteedit is only looking for the OSS sequencer (apparently something is
> not right with the underlying Tse3 library - I have to look at that at
> some point) and the device file for it is missing as udev does not
> create it. 
> You could do this (as root) to test:
>   cd /dev
>   ./MAKEDEV sequencer
>   chown sequencer YOUR_ACCOUNT_NAME
> After this you should be able to restart noteedit and it will (should?)
> find the oss sequencer device. 
> You could move the device node to /etc/udev/devices so that it will be
> recreated on reboot:
>   mv /dev/sequencer /etc/udev/devices/
> If you reboot the device should be recreated and should have the right
> permissions after you login (at least that happens in my tests).
> -- Fernando
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA@ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma

Nick Metrowsky                   | http://users.frii.com/~nmetro/
3624 Oakwood Drive               | E-Mail: nmetro@frii.com
Longmont, CO 80503-7560          | Phone: (303)485-5696