[PlanetCCRMA] ipw2100 wireless and ccrma kernel

Ken Schutte kschutte@csail.mit.edu
Mon Jun 6 15:56:01 2005

Thanks for the replies.  I tried creating /usr/lib/hotplug/firmware/ and
copying the firmware in there.  (I used /lib/firmware because my
/etc/hotplug/firmware.agent defined FIRMWARE_DIR=/lib/firmware), and
rebooted, and still no luck.

Here are some commands and outputs:
# /sbin/modprobe ipw2100
# /sbin/lsmod | grep ipw
ipw2100               153156  0
ieee80211              41028  1 ipw2100
ieee80211_crypt         7940  2 ipw2100,ieee80211
# grep ipw /var/log/messages
Jun  6 17:04:47 localhost kernel: ipw2100: Intel(R) PRO/Wireless 2100
Network Driver, 1.1.0
Jun  6 17:04:47 localhost kernel: ipw2100: Copyright(c) 2003-2004 Intel
# /sbin/ifup eth1
ipw2100 device eth1 does not seem to be present, delaying initialization.

I have "alias eth1 ipw2100" in /etc/modules.conf

I also have the following files:
$ find /etc/ -name '*eth1'

All of which contain:

This is an IBM Thinkpad X40 with FC3.  rpm -q shows that I have:
I've been searching google with no luck on things to try, it's tough 
because I can't seem to find any error messages to work from, eth1 just 
does not show up.  Thanks.


Jamie Bullock wrote:
> Hi!
> I am almost certain you won't need to rebuild your Kernel, all the right
> crypto drivers area already there. It might matter where the firmware
> goes though. I have an ipw2200, and the firmware is
> in /usr/lib/hotplug/firmware/. Also, what do the results of grep
> ipw /var/log/messages give?
> Jamie
> On Sun, 2005-06-05 at 13:52 -0400, Ken Schutte wrote:
>>Does anyone have ipw2100 module working with the
>>2.6.10-2.1.ll.rhfc3.ccrma kernel?  I've been trying to get this to work
>>for a while but I'm totally stuck.  I've compiled it and put the
>>firmware in /lib/firmware, and when I /sbin/modprobe ipw2100, I get:
>>ipw2100: Intel(R) PRO/Wireless 2100 Network Driver, 1.1.0
>>ipw2100: Copyright(c) 2003-2004 Intel Corporation
>>in dmesg.  But, when I try '/sbin/ifup eth1', I get "ipw2100 device eth1 
>>does not seem to be present, delaying initialization."
>>Do I have to rebuild the kernel?  Any advice would be appreciated.