[PlanetCCRMA] FC2/stable - FC2->FC4, start jack, hard lock

Mark Knecht Mark Knecht <markknecht@gmail.com>
Tue Jul 12 13:15:02 2005

Hi Fernando,
   A status report. If you have ideas on what I should try next please
let me know.

   I've done the FC2-FC4 upgrade. I managed last evening to get the
system upgraded via apt-get install to what appears like a reasonable
set of update. I've installed what I think is the latest stable FC4
kernel. Please correct me if I'm wrong on that account:

[mark@Godzilla ~]$ uname -a
Linux Godzilla 2.6.11-1.1369_FC4 #1 Thu Jun 2 22:55:56 EDT 2005 i686
athlon i386 GNU/Linux
[mark@Godzilla ~]$

  At this point I'm communicating with you from the upgraded machine.
Networking, etc., are all apparently working fine. Hard drive
performance is about where it was with FC2:

[root@Godzilla ~]# hdparm -tT /dev/hda

 Timing cached reads:   1132 MB in  2.00 seconds = 564.96 MB/sec
 Timing buffered disk reads:   88 MB in  3.06 seconds =  28.76 MB/sec
[root@Godzilla ~]#

Graphics performance is a bit low, I think, but not all that bad for
this old card:

[root@Godzilla ~]# glxgears
1111 frames in 5.0 seconds = 222.200 FPS
1320 frames in 5.0 seconds = 264.000 FPS
1435 frames in 5.0 seconds = 287.000 FPS

[root@Godzilla ~]#

   So, like a good Linux audio user I tried twice try to run Jack
using QJackCtl. Both times the machine hung hard. I could not ssh in
from other machines and only a power cycle got me back. The third time
I first tried running Jack without realtime and it worked, and after
that I tried running Jack with realtime and it is working as I write
this. None the less I'm a bit concerned at this point that I've taken
a fairly large backstep in terms of stability. I do not remember this
machine locking up running Jack in a very long time.

   Here's the basics on the machine:

[root@Godzilla ~]# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]
00:06.0 Unknown mass storage controller: Promise Technology, Inc.
PDC20265 (FastTrak100 Lite/Ultra100) (rev 02)
00:0c.0 FireWire (IEEE 1394): Texas Instruments TSB12LV23 IEEE-1394 Controller
00:0d.0 Ethernet controller: Intel Corporation 82557/8/9 [Ethernet Pro
100] (rev 05)
00:0e.0 FireWire (IEEE 1394): Texas Instruments TSB82AA2 IEEE-1394b
Link Layer Controller (rev 01)
00:0f.0 Multimedia audio controller: Xilinx Corporation RME Hammerfall
DSP (rev 68)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8233 PCI to ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 1b)
00:11.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 1b)
00:11.4 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 1b)
01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro
AGP 1X/2X (rev 5c)
[root@Godzilla ~]#

   Do you think I'm using the best kernel for this machine? Shall I
try some PlanetEdge kernel possibly?