[PlanetCCRMA] apt-get questions for upgrade FC1 to FC2

Tom Poe tompoe@peacemail.com
Sun Jul 3 17:44:02 2005


I'm running FC1 and want to upgrade to FC2.  I
have changed the sources.list to get fedora/2/. .
. on apt-get dist-upgrade command.  I've also
changed the apt.conf file to reflect the FC2
kernel code found at:
http://ccrma.stanford.edu/planetccrma/software/installtwosix.html

I am running apt 0.5.15cnc2 at this time.  If I
understand the instructions, that is the correct
apt version?

I ran apt-get update, followed by apt-get
dist-upgrade, and, when calculating, got a FAILED
Calculating Upgrade... Failed
The following packages have unmet dependencies:
 SDL: Depends: libasound.so.2
      Depends: libasound.so.2(ALSA_0.9)
 arts: Depends: libasound.so.2
       Depends: libasound.so.2(ALSA_0.9)
 esound-devel: Depends: alsa-lib-devel but it is
not going to be installed
               Depends: esound (= 1:0.2.34-2)
but 1:0.2.31-1 is to be installed
jack-audio-connection-kit: Depends: libasound.so.2
                            Depends:
libasound.so.2(ALSA_0.9)
 kdelibs: Depends: libasound.so.2
          Depends: libasound.so.2(ALSA_0.9)
 kdelibs-devel: Depends: arts-devel but it is
not going to be installed
 mammut: Depends: libsndlib.so
 pd: Depends: libasound.so.2
     Depends: libasound.so.2(ALSA_0.9)
E: Error, pkgProblemResolver::Resolve generated
breaks, this may be caused by held packages.
[root@sound apt]#

I have libasound.so.2 in:
[root@sound apt]# locate libasound.so.2
/usr/lib/libasound.so.2.0.0
/usr/lib/libasound.so.2

Where should I copy the file so that apt-get can
find it?

Any apt-get help appreciated


Care2 make the world greener!
Help Make Poverty History  Sign the ONE Declaration: 
http://www.care2.com/go/z/endpoverty

http://www.Care2.com  Free e-mail. 100MB storage.  Helps charities.