[PlanetCCRMA] Lost sound on FC3

Ron Pepper feffer777@yahoo.com
Wed Feb 23 13:33:01 2005

I'm new to Linux and have a dell P4 desktop machine which is set up
to dual boot linux and xp. The sound card is a built in Soundblaster
Live! and isn't recognized properly by FC3 on install. After checking
the forums, I found that this is a known issue with Dell Dimension
4550. Linux sees the soundcard chip as emu10k1, but it is actually
somewhat different. The ALSA site shows my chip to be emu10k1x and
subsequent checks confirmed this. 

So I followed the directions on the ALSA site to configure and
install the new module. Since I didn't really know what I was doing,
I just followed what was written and asked for help from the ALSA
list when I got stuck. After much struggle, I finally got the sound
to work. System sounds worked and ogg files I downloaded to the hd
worked. I could play them from sites as streaming audio as well. I
couldn't get Gnome player to play inserted CD's, however. I would get
a "disk error" message from the player. I thought this might be a
permissions issue as I got error messages when I tried from the ALSA

Permissions were never set properly, according to ALSA: 
The snddevices script sets the permissions for the devices it creates
to root. You should
        "chmod a+rw /dev/dsp /dev/mixer /dev/sequencer /dev/midi" 

When I tried this, I got:
>[root@localhost alsa-driver-1.0.8]# chmod a+rw /dev/dsp /dev/mixer
>/dev/sequencer /dev/midi
>chmod: cannot access `/dev/dsp': No such file or directory
>chmod: cannot access `/dev/mixer': No such file or directory
>chmod: cannot access `/dev/sequencer': No such file or directory
>chmod: cannot access `/dev/midi': No such file or directory

>From the list, I was advised:

"If you make sure your system has a group named "audio", then the
snddevices script will create devices with a group attribute of

In /dev/snd for example:
crw-rw----    1 root     audio    116,  24 Feb 20 11:40 pcmC0D0c

Then all you have to do is ensure that your users are members of a
named "audio".

on my system:
cat /etc/group | grep audio"

Unfortunately, I didn't really understand what I was doing and now
have lost all sound! I'm a newbie and don't know how to troubleshoot
this. Help would be appreciated!

Thanks, Ron

The result of lsmod:
[rp@rp ~]$ /sbin/lsmod
Module                  Size  Used by
vfat                   12609  1
fat                    39905  1 vfat
parport_pc             26629  1
lp                     12077  0
parport                37001  2 parport_pc,lp
autofs4                23493  0
sunrpc                156325  1
dm_mod                 55637  0
video                  15813  0
button                  6609  0
battery                 9285  0
ac                      4805  0
md5                     4033  1
ipv6                  231681  8
joydev                  9217  0
uhci_hcd               31449  0
ehci_hcd               35273  0
hw_random               5845  0
i2c_i801                8141  0
i2c_core               20801  1 i2c_i801
emu10k1_gp              3649  0
gameport                4929  1 emu10k1_gp
snd_emu10k1x           21668  2
snd_rawmidi            26400  1 snd_emu10k1x
snd_seq_device          9100  1 snd_rawmidi
snd_ac97_codec         67064  1 snd_emu10k1x
snd_pcm_oss            48544  0
snd_mixer_oss          17920  2 snd_pcm_oss
snd_pcm                90888  3
snd_timer              29572  1 snd_pcm
snd                    54244  10
soundcore              10017  2 snd
snd_page_alloc          9988  2 snd_emu10k1x,snd_pcm
e100                   39873  0
mii                     4673  1 e100
floppy                 57841  0
ext3                  116297  2
jbd                    69977  1 ext3

[rp@rp ~]$ cat /etc/modprobe.conf
alias eth0 e100
alias snd-card-0 snd-emu10k1x
options snd-card-0 index=0
install snd-emu10k1x /sbin/modprobe --ignore-install snd-emu10k1x &&
/usr/sbin/a lsactl restore >/dev/null 2>&1 || :
remove snd-emu10k1x { /usr/sbin/alsactl store >/dev/null 2>&1 || : ;
}; /sbin/mo dprobe -r --ignore-remove snd-emu10k1x
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around