[PlanetCCRMA] (no subject)

Robert Gruendler dobre@gmx.at
Tue Feb 22 09:43:02 2005


Hi list,

i'm new to linux-audio and first of all i wanna shout out big thanks to
Planet-CCRMA! As a linux newbie i fiddled around 2 weeks now to make my
linux-box do the audio thing, with very bad results. After checking out
CCRM,  and installing everything from their repository, now it all works
flawlessly :) !

Well, nearly everything works... i'm having troubles getting my Evolution
UC-33 midi-controller to work with Pd. 

I know this issue has been discussed already here, but i simply can't get
this thing working.

I have followed the steps in the USB-Midi-Howto, i added usb-midi and audio
to /etc/hotplug/blacklist. I edited my /etc/modprobe.conf the way explained
in CCRM Install documentation.

Other apps (muse, jack) do recognize the controller.

Here are some outputs that might help:

/sbin/lsmod | grep usb

usblp                  12800  0
snd_usb_audio          68928  0
snd_usb_lib            14208  1 snd_usb_audio
snd_pcm               108680  7
snd_usb_audio,snd_via82xx,snd_ac97_codec,snd_pcm_oss
snd_rawmidi            27552  3 snd_seq_midi,snd_usb_lib,snd_mpu401_uart
snd                    68484  20
snd_seq_midi,snd_seq_midi_event,snd_seq,snd_usb_audio,snd_usb_lib,snd_via82xx,snd_ac97_codec,
snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device

cat /proc/asound/cards

0 [V8235          ]: VIA8233 - VIA 8235
                     VIA 8235 with VT1616i at 0xe000, irq 22
1 [Controller     ]: USB-Audio - UC-33 USB MIDI Controller
                     Evolution Electronics Ltd. UC-33 USB MIDI Controller at
usb-0000:00:10.2-1, ful


cat /proc/asound/devices


17: [0- 1]: digital audio playback
15: [0- 1]: digital audio capture
16: [0- 0]: digital audio playback
24: [0- 0]: digital audio capture
 0: [0- 0]: ctl
 1:       : sequencer
33:       : timer
40: [1- 0]: raw midi
32: [1- 0]: ctl


/etc/modprobe.conf

alias eth0 via-rhine
alias snd-card-0 snd-via82xx
options snd-card-0 index=0 card_limit=3
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-via82xx
alias snd-card-1 snd-usb-audio
options snd-usb-audio index=1
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd

# ALSA portion
alias char-major-116 snd
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss



i've tried starting pd with the following flags, no luck

pd -jack -mididev 1 / 2 / 3    <---- on at a time of course
pd -jack -mididev 32 / 33 / 34 / 39 / 40 /41     <----- same here


and all those flags without -jack

i turned audio on in pd, and tried it with "test audio and midi" patch. I've
opened and selected the midi setup menu every time.

Strangly, when i select the Alsa-Driver, and go to Audio Setup menu, i can
see the UC-33 entry (one with "hardware", and one with "plug-in"), but
selecting those, of course, does not work.

Any hint would be highly appreciated!!

thanks for your help


Robert


-- 
DSL Komplett von GMX +++ SupergŁnstig und stressfrei einsteigen!
AKTION "Kein Einrichtungspreis" nutzen: http://www.gmx.net/de/go/dsl