[PlanetCCRMA] Re: Rosegarden problem

Kjetil Svalastog Matheussen k.s.matheussen@notam02.no
Sat Feb 19 06:21:02 2005

Jamie Bullock:
> Dear Fernando,
> I tried all of your suggestions, but to no avail. It was a good
> excercise in clearing traces of fc2 from my system though! I've moved on
> to trying to get the app to build from source. Using your 0.9 series
> source packages I get a new error. I run:
> ./configure --with-qt-dir=/usr/lib/qt-3.3/ --with-qt-includes=/usr/lib/qt-3.3/include/ --with-qt-libraries=/usr/lib/qt-3.3/lib/
> and configure fails at:
> checking for Qt... configure: error: Qt (>= Qt 3.0) (library qt-mt) not found. Please check your installation!
> For more details about this problem, look at the end of config.log.
> Make sure that you have compiled Qt with thread support!
> I checked, and libqt-mt.so is definitely in qt-3.3/lib.
> Any ideas?

I think I had the same problem recently trying to compile up Muse.
My problem was that I have set the QTDIR environment variable:

[kjetism@bruno localdomain]$ env |grep QT

Perhaps this will work:

export QTDIR=/usr/lib/qt-3.3
./configure --with-qt-dir=/usr/lib/qt-3.3/