[PlanetCCRMA] Re: JACK isn't getting realtime

Neil Klepeis nklepeis@sbcglobal.net
Mon Feb 14 12:20:02 2005

Fernando Lopez-Lezcano wrote:
> On Sat, 2005-02-12 at 16:51, Neil Klepeis wrote:
>>I'm having trouble getting the FC3 kernels working in JACK RT mode (both 
>>  the stable and planetedge kernels give a RT error, see below).   I 
>>think maybe my video is messing things up.   Are there kernel sources 
>>available so I can recompile my video drivers?
>>Note:  My machine is:  Athlon, Radeon VE, AWE64, Abit VIA mb
> I had not noticed this, are you trying to use a SoundBlaster AWE64 with
> jack? That will probably not work as (AFAIK) the AWE64 does not have
> symetric i/o, it will only do 16 bit dma in one direction (only 8 bit in
> the other). 

As I recall, the SB AW64 can do 16 bit capture OR playback, but can only 
do 8bit playback during duplex operation (and so duplex mode probably 
has no hope of working at all under JACK).

I had already tried just starting JACK with 16-bit playback using 
qjackctl on the SB AWE64, but there was no RT capability (w/ fresh and 
pure FC3/planet install).

Just now, I tried starting JACK by hand on the command line with: jackd 
-R -dalsa -dhw:0 -r44100 -P ...but still no luck.  I get the same kind 
of stuff:
JACK: unable to mlock() port buffers: Cannot allocate memory
jack_create_thread: error -1 switching current thread to rt for 
inheritance: Unknown error 4294967295
cannot start watchdog thread
cannot load driver module alsa

BUT, interestingly:  Starting _without_ RT capability seems OK (no 
errors on startup and ardour can playback imported audio with no problem):
jackd -dalsa -dhw:0 -r44100 -C
jackd -dalsa -dhw:0 -r44100 -P

But (as expected) duplex dies w/:
jackd -dalsa -dhw:0 -r44100
Sorry. The audio interface "hw:0" doesn't support any of the hardware 
sample formats that JACK's alsa-driver can use.
ALSA: cannot configure capture channel
cannot load driver module alsa

Could it be that attempting to use RT in the kernel is interfering with 
the alsa driver?    Since starting JACK w/o RT seems to actually work, 
maybe I don't need RT for basic 2-channel stuff.  I don't seem to get 
many xruns (yet).

Hmmmm, I guess I'll also try my HDSP (currently on another machine) and 
see if things for RT look up.