[PlanetCCRMA] No sound with FC2, Delta 44, Pentium 4

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Wed Feb 9 10:28:01 2005

On Wed, 2005-02-09 at 07:29, Roger B. Dannenberg wrote:
> I just switched from RedHat 8 to Fedora Core 2 and now I cannot get any
> sound output. When I boot or run dmesg, I see errors like:
> snd_ice1712: Unknown symbol snd_card_new
> snd_ice1712: Unknown symbol snd_iprintf
> snd_ice1712: Unknown symbol snd_pcm_lib_malloc_pages
> snd_ice1712: Unknown symbol snd_pcm_lib_ioctl
> snd_ice1712: Unknown symbol snd_pcm_lib_free_pages
> snd_ice1712: Unknown symbol snd_cs8427_iec958_build
> snd_ice1712: Unknown symbol snd_akm4xxx_reset
> ...
> and if I try to start alsasound, I get many messages like:
> Starting sound driver snd-ice1712 WARNING: Error inserting snd
> (/lib/modules/2.6.10-0.5.rdt.rhfc2.ccrmasmp/updates/acore/snd.ko): Unknown
> symbol in module, or unknown parameter (see dmesg)
> WARNING: Error inserting snd_seq_device
> (/lib/modules/2.6.10-0.5.rdt.rhfc2.ccrmasmp/updates/acore/seq/snd-seq-device
> .ko): Unknown symbol in module, or unknown parameter (see dmesg)
> ...
> I found a similar problem described in the archives, but no solution was
> posted. I'm using the 2.6.10-0.5.rdt.rhfc2.ccrmasmp kernel, but I see the
> same thing with the non-smp kernel and the originally installed FC2 kernel.
> Any ideas?
> I guess sound is supposed to work when you install FC2. If that's not the
> case, how to you troubleshoot? It looks like the FC2 install tried to
> preserve .conf files in /etc, so I don't have much faith that these are
> correct (although they worked with RH8).

Was this an upgrade or a fresh install?

I would first see if the installed modules are the correct architecture.
Do a "/sbin/depmod -ae", do you see any unknown symbol errors? If not
then probably you have the right packages installed. 

If that's the case (no errors) then probably the problem is wrong
parameters in the configuration file. In fc2 that would be
/etc/modprobe.conf (it used to be /etc/modules.conf when running kernel
2.4.x). If this is an upgrade check that /etc/modules.conf is not there,
although I don't know if it is actually ignored or not. 

So, check the options lines in /etc/modprobe.conf, or post them. If you
change /etc/modprobe.conf do a "/sbin/depmod -a" before trying to load
alsa again. 

-- Fernando