[PlanetCCRMA] No sound with FC2, Delta 44, Pentium 4

Roger B. Dannenberg rbd@cs.cmu.edu
Wed Feb 9 07:30:02 2005

I just switched from RedHat 8 to Fedora Core 2 and now I cannot get any
sound output. When I boot or run dmesg, I see errors like:

snd_ice1712: Unknown symbol snd_card_new
snd_ice1712: Unknown symbol snd_iprintf
snd_ice1712: Unknown symbol snd_pcm_lib_malloc_pages
snd_ice1712: Unknown symbol snd_pcm_lib_ioctl
snd_ice1712: Unknown symbol snd_pcm_lib_free_pages
snd_ice1712: Unknown symbol snd_cs8427_iec958_build
snd_ice1712: Unknown symbol snd_akm4xxx_reset

and if I try to start alsasound, I get many messages like:

Starting sound driver snd-ice1712 WARNING: Error inserting snd
(/lib/modules/2.6.10-0.5.rdt.rhfc2.ccrmasmp/updates/acore/snd.ko): Unknown
symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_seq_device
.ko): Unknown symbol in module, or unknown parameter (see dmesg)

I found a similar problem described in the archives, but no solution was
posted. I'm using the 2.6.10-0.5.rdt.rhfc2.ccrmasmp kernel, but I see the
same thing with the non-smp kernel and the originally installed FC2 kernel.
Any ideas?

I guess sound is supposed to work when you install FC2. If that's not the
case, how to you troubleshoot? It looks like the FC2 install tried to
preserve .conf files in /etc, so I don't have much faith that these are
correct (although they worked with RH8).