[PlanetCCRMA] Re: Problem with /usr/bin/jackstart

Mark Knecht markknecht@gmail.com
Sat Aug 6 09:05:02 2005

On 8/5/05, Ron Pepper <feffer777@yahoo.com> wrote:
> --- Mark Knecht <markknecht@gmail.com> wrote:
> > On 8/4/05, Ron Pepper <feffer777@yahoo.com> wrote:
> >
> > > Tried again with CCRMA kernal, albeit a little older one. Still
> > no
> > > go. Any ideas?
> >
> > OK, it's either that you cannot do realtime or you cannot do Jack.
> > Please try it without realtime:
> >
> > jackd -d alsa -d hw
> >
> > Also does alsamixer run? Are you getting sound at all?
> >
> > - Mark
> Yes, alsamixer runs and I get sound from all sources. Alsaplayer,
> xmms, rhythm-box all work fine, but none of the recorders work at
> all.
> Trying "jackd -d alsa -d hw" gets me non-stop flow of the following:
> **** alsa_pcm: xrun of at least 0.034 msecs
> etc. etc.

OK, so the default settings are not good WRT to xruns on this system.
You could try

jackd -d alsa -r 44100 -n 4 -p 1024 -d hw

This sets the sample rate and the basic transfer size. See man jackd
for more info. If this still doesn't work then try raising -p to
2048/4096/etc. as an experiement.

The issue here is why you are not able to run realtime. Do you have
the realtime-lsm module loaded? As root


If not then you can try loading it, but before you do you need to
create a realtime group to give access to these capabilities. We'll
get there when we know a bit more.

Can you also provide the output of:

cat /proc/asound/version
cat /proc/interrupts