[PlanetCCRMA] Fresh Installation, IRQ, and USB

Big Bear docbear@gmail.com
Tue Aug 2 22:43:01 2005

Fernando Lopez-Lezcano wrote:

>On Tue, 2005-08-02 at 04:42, Da Xiong wrote:
>>Just installed CCRMA on my FC3 machine, but now USB will not work.
>>During the udev part of boot, system sets up storage and audio, then
>>disables IRQ 21. After that my USB hub does not work.
>>Modprobe.conf looked like this before CCRMA:
>>alias eth0 via-rhine
>>alias snd-card-0 snd-maestro3
>>options snd-card-0 index=0  
>>install snd-maestro3 /sbin/modprobe --ignore-install snd-maestro3 &&
>>/usr/sbin/alsactl restore >/dev/null 2>&1 || :
>>remove snd-maestro3 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ;
>>}; /sbin/modprobe -r --ignore-remove snd-maestro3
>>alias usb-controller ehci-hcd
>>alias usb-controller1 uhci-hcd
>>Running Linux version 2.6.12-1.1372_FC3
>>(bhcompile@tweety.build.redhat.com) (gcc version 3.4.3 20050227 (Red
>>Hat 3.4.3-22)) #1 Fri Jul 15 00:59:10 EDT 2005
>>Now modprobe.conf looks like this:
>>alias eth0 via-rhine
>>alias snd-card-0 snd-maestro3
>>options snd-card-0 index=0  
>>install snd-maestro3 /sbin/modprobe --ignore-install snd-maestro3 &&
>>/usr/sbin/alsactl restore >/dev/null 2>&1 || :
>>remove snd-maestro3 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ;
>>}; /sbin/modprobe -r --ignore-remove snd-maestro3
>>alias usb-controller ehci-hcd
>>alias usb-controller1 uhci-hcd
>>Running Linux version 2.6.10-2.1.ll.rhfc3.ccrma
>>(machbuild@cmn37.Stanford.EDU) (gcc version 3.4.2 20041017 (Red Hat
>>3.4.2-6.fc3)) #1 Thu Dec 30 03:08:13 EST 2004
>>I don't see any modprobe differences, but I am really stumped.
>>Something about udev?
>Have you tried the planetccrma-core-edge meta package? That includes a
>newer kernel with the realtime preempt patches. Maybe it will work
>better. Do you have a log of the what happens when irq21 is disabled? 
>-- Fernando
I just tried planetccrma-core-edge meta package. Same results. Here is a 
copy of dmesg. I can see there is a problem there, but am unfortunately 
not smart enough to solve it on my own. Any other suggestions?

Linux version 2.6.11-0.3.rdt.rhfc3.ccrma (machbuild@cmn37.Stanford.EDU) 
(gcc version 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)) #1 Tue Mar 22 
02:02:01 EST 2005
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 0000000010000000 (usable)
 BIOS-e820: 00000000fec00000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
256MB LOWMEM available.
found SMP MP-table at 000f5340
On node 0 totalpages: 65536
  DMA zone: 4096 pages, LIFO batch:1
  Normal zone: 61440 pages, LIFO batch:15
  HighMem zone: 0 pages, LIFO batch:1
DMI 2.2 present.
ACPI: Unable to locate RSDP
Intel MultiProcessor Specification v1.4
    Virtual Wire compatibility mode.
OEM ID: OEM00000 Product ID: PROD00000000 APIC at: 0xFEE00000
Processor #0 15:2 APIC version 17
I/O APIC #2 Version 17 at 0xFEC00000.
Enabling APIC mode:  Flat.  Using 1 I/O APICs
Processors: 1
Allocating PCI resources starting at 10000000 (gap: 10000000:eec00000)
Built 1 zonelists
Kernel command line: ro root=/dev/VolGroup00/LogVol00 vga=788 selinux=0
mapped APIC to ffffd000 (fee00000)
mapped IOAPIC to ffffc000 (fec00000)
Initializing CPU#0
PID hash table entries: 2048 (order: 11, 32768 bytes)
Detected 2390.357 MHz processor.
Using tsc for high-res timesource
Console: colour dummy device 80x25
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 254596k/262144k available (2297k kernel code, 6988k reserved, 
693k data, 204k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay loop... 4718.59 BogoMIPS (lpj=2359296)
Security Framework v1.0.0 initialized
SELinux:  Disabled at boot.
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU: After generic identify, caps: bfebfbff 00000000 00000000 00000000 
00004400 00000000 00000000
CPU: After vendor identify, caps: bfebfbff 00000000 00000000 00000000 
00004400 00000000 00000000
CPU: Trace cache: 12K uops, L1 D cache: 8K
CPU: L2 cache: 128K
CPU: After all inits, caps: bfebfbff 00000000 00000000 00000080 00004400 
00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU0: Intel P4/Xeon Extended MCE MSRs (12) available
CPU: Intel(R) Celeron(R) CPU 2.40GHz stepping 09
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
desched cpu_callback 3/00000000
ksoftirqd started up.
softirq RT prio: 24.
desched cpu_callback 2/00000000
..TIMER: vector=0x31 pin1=2 pin2=0
checking if image is initramfs... it is
Freeing initrd memory: 957k freed
desched thread 0 started up.
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xfb290, last bus=1
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20050211
ACPI: Interpreter disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI: disabled
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
PCI: Via IRQ fixup
PCI: Using IRQ router VIA [1106/3177] at 0000:00:11.0
PCI->APIC IRQ transform: 0000:00:08.0[A] -> IRQ 16
PCI->APIC IRQ transform: 0000:00:10.0[A] -> IRQ 21
PCI->APIC IRQ transform: 0000:00:10.1[B] -> IRQ 21
PCI->APIC IRQ transform: 0000:00:10.2[C] -> IRQ 21
PCI->APIC IRQ transform: 0000:00:10.3[D] -> IRQ 19
PCI->APIC IRQ transform: 0000:00:11.1[A] -> IRQ 11
PCI->APIC IRQ transform: 0000:00:12.0[A] -> IRQ 23
PCI->APIC IRQ transform: 0000:01:00.0[A] -> IRQ 16
TC classifier action (bugs to netdev@oss.sgi.com cc hadi@cyberus.ca)
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16ac)
audit: initializing netlink socket (disabled)
audit(1123046166.031:0): initialized
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Initializing Cryptographic API
ksign: Installing public key data
Loading keyring
- Added public key A8E0E90377AFA90B
- User ID: Red Hat, Inc. (Kernel Module GPG key)
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
vesafb: framebuffer at 0xd8000000, mapped to 0xd0880000, using 1875k, 
total 65536k
vesafb: mode is 800x600x16, linelength=1600, pages=3
vesafb: protected mode interface info at c000:c060
vesafb: scrolling: redraw
vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
Console: switching to colour frame buffer device 100x37
fb0: VESA VGA frame buffer device
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected VIA PT800 chipset
agpgart: Maximum main memory to use for agp memory: 204M
agpgart: AGP aperture is 128M @ 0xd0000000
[drm] Initialized drm 1.0.0 20040925
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing enabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller at PCI slot 0000:00:11.1
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt8235 (rev 00) IDE UDMA133 controller on pci0000:00:11.1
    ide0: BM-DMA at 0xe000-0xe007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xe008-0xe00f, BIOS settings: hdc:DMA, hdd:DMA
Probing IDE interface ide0...
hda: WDC WD800BB-00JHA0, ATA DISK drive
hdb: HL-DT-ST GCE-8483B, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
hdc: ST340014A, ATA DISK drive
ide1 at 0x170-0x177,0x376 on irq 15
Probing IDE interface ide2...
Probing IDE interface ide3...
Probing IDE interface ide4...
Probing IDE interface ide5...
hda: max request size: 128KiB
hda: 156301488 sectors (80026 MB) w/2048KiB Cache, CHS=65535/16/63, 
hda: cache flushes supported
 hda: hda1 hda2
hdc: max request size: 1024KiB
hdc: 78165360 sectors (40020 MB) w/2048KiB Cache, CHS=16383/255/63, 
hdc: cache flushes supported
 hdc: hdc1
hdb: ATAPI 52X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
hdd: ATAPI 48X DVD-ROM drive, 512kB Cache, UDMA(33)
ide-floppy driver 0.99.newide
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
mice: PS/2 mouse device common for all mice
input: AT Translated Set 2 keyboard on isa0060/serio0
input: ImPS/2 Generic Wheel Mouse on isa0060/serio1
md: md driver 0.90.1 MAX_MD_DEVS=256, MD_SB_DISKS=27
padlock: VIA PadLock not detected.
NET: Registered protocol family 2
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP established hash table entries: 16384 (order: 5, 131072 bytes)
TCP bind hash table entries: 16384 (order: 4, 65536 bytes)
TCP: Hash tables configured (established 16384 bind 16384)
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
Freeing unused kernel memory: 204k freed
device-mapper: 4.4.0-ioctl (2005-01-12) initialised: dm-devel@redhat.com
cdrom: open failed.
cdrom: open failed.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
FDC 0 is a post-1991 82077
via-rhine.c:v1.10-LK1.2.0-2.6 June-10-2004 Written by Donald Becker
eth0: VIA Rhine II at 0xe2001000, 00:e0:4c:c5:52:98, IRQ 23.
eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 0021.
ehci_hcd 0000:00:10.3: EHCI Host Controller
ehci_hcd 0000:00:10.3: irq 19, pci mem 0xe2000000
ehci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:10.3: USB 2.0 initialized, EHCI 1.00, driver 10 Dec 2004
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 6 ports detected
USB Universal Host Controller Interface driver v2.2
uhci_hcd 0000:00:10.0: UHCI Host Controller
irq 21: nobody cared!
 [<c0141564>] __report_bad_irq+0x24/0x80 (8)
 [<c014167e>] note_interrupt+0x8e/0xb0 (20)
 [<c0141407>] do_hardirq+0x117/0x130 (24)
 [<c0141420>] do_irqd+0x0/0xa0 (24)
 [<c0141483>] do_irqd+0x63/0xa0 (4)
 [<c0135056>] kthread+0x96/0xe0 (28)
 [<c0134fc0>] kthread+0x0/0xe0 (16)
 [<c01012dd>] kernel_thread_helper+0x5/0x18 (16)
| preempt count: 00000002 ]
| 2-level deep critical section nesting:
.. [<c014138f>] .... do_hardirq+0x9f/0x130
.....[<00000000>] ..   ( <= 0x0)
.. [<c013613d>] .... print_traces+0xd/0x40
.....[<00000000>] ..   ( <= 0x0)

[<c02a2b60>] (usb_hcd_irq+0x0/0x70)
Disabling IRQ #21
uhci_hcd 0000:00:10.0: irq 21, io base 0xd400
uhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
uhci_hcd 0000:00:10.1: UHCI Host Controller
uhci_hcd 0000:00:10.1: irq 21, io base 0xd800
uhci_hcd 0000:00:10.1: new USB bus registered, assigned bus number 3
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
uhci_hcd 0000:00:10.2: UHCI Host Controller
uhci_hcd 0000:00:10.2: irq 21, io base 0xdc00
uhci_hcd 0000:00:10.2: new USB bus registered, assigned bus number 4
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
usb 2-1: new full speed USB device using uhci_hcd and address 2
uhci_hcd 0000:00:10.0: Unlink after no-IRQ?  Controller is probably 
using the wrong IRQ.
usb 2-1: khubd timed out on ep0in
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
EXT3 FS on dm-0, internal journal
cdrom: open failed.
cdrom: open failed.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hda1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
Adding 1048568k swap on /dev/VolGroup00/LogVol01.  Priority:-1 extents:1
usb 2-1: khubd timed out on ep0out

Thanks, John