[PlanetCCRMA] FC3 versus FC2 - experiences (double edge?)

Mark Knecht Mark Knecht <markknecht@gmail.com>
Tue Apr 12 13:33:02 2005

On 12 Apr 2005 13:07:55 -0700, Fernando Lopez-Lezcano
<nando@ccrma.stanford.edu> wrote:
> On Tue, 2005-04-12 at 12:00, Mark Knecht wrote:
> > On Apr 12, 2005 6:55 AM, Shayne O'Connor <forums@machinehasnoagenda.com> wrote:
> >
> > > in any case, had band practice tonight and took my CCRMA box along
> > > (configured as mentioned in my previous post) to provide drums and
> > > multi-track recording - performed admirably for 3 hours straight ...
> > > that's what i like :)
> >
> > Gah-roove-ee!
> >
> > I'll be trying out Fernando's newest Edge kernel today. My attempt to
> > run the Gentoo ck-sources kerenl did not have such good results as
> > they did on my Gentoo box. It was a very strange boot where it starts
> > booting but then says permissions are all wrong and it cannot
> > continue. Type Control-D to do maintanence, etc. Ugly. The very same
> > source code tree on the laptop running Gentoo was wonderful.
> What is complaining about permissions? This is FC3, right? It may be
> selinux acting up (the selinux in the new kernel is different or
> something like that), you could boot into a kernel that works and
> disable selinux (in "System Settings", "Security Level", SElinux tab)
> -- Fernando

   FC2 in my case. It's the ck4 kernel I built, not yours, that's
complaining. What part of the kernel I'm not sure. To review:

1) Under Gentoo on my laptop I built the Con Kolivas (sp?) kernel. It
worked very well on a short test.

2) I tarred up the /usr/src/linux-2.6.11-ck4 directory and brought it
over to my normal Planet box where I run Ardour.

3) I untarred the kerenl, set the Linux link, did a make mrproper,
dropped in a copy of the .config file from the Gentoo box, changed a
couple of things that were chipset specific and built the kernel. The
build went fine, everything installed. modified grub.conf and

4) The kernel starts coming up and up to the point where it finally
finds the file system and starts with the list of [OK]'s everythign
looks pretty normal. However at that point it starts complaining about
the hard drive not having the right permissions, and to a great extent
complaining that the whole ext3 drive is non-compliant. A very weird
set of messages.

5) It stops pretty quickly asking me to do disk maintanence. I do a
reboot instead back into your older PlanetEdge kernel and everything
is fine.

   As I say, this was intended to be a quick experiment of the CK
stuff since it worked well under Gentoo, but it hasn't worked well
here as of yet.

   If I was to do this again I guess I'd go get the vanilla kernel and
figure out how to apply his patches instead of using Gentoo's portage,

   Hope that clears things up.

   BTW - The kerenl is now allowing you to choose 3 IO schedulers. Are
you choosing all of them? One of them? Which one?

   BTW #2: Would you consider turning on /proc/config.gz?