[PlanetCCRMA] amidi not sending data

Jason Balicki kodak@frontierhomemortgage.com
Sun Apr 3 21:26:00 2005

Me again.

I gave up on LegaSynth, as it appears the
author has too.  Anyway, I really, really
want to get some SID sounds into my music.

I have a Commodore 64 sitting on my desk
running M64.  M64 can send and receive
data via MIDI sysex, and I've done so
in Windows using the same hardware setup
I'm using right now.  (Yes, the 64 has a
MIDI interface. :)

If I do amidi -l I get:

Device	Name
hw:0,0	EMU10K1 MPU-401 (UART)
hw:0,1	Emu10k1 Synth MIDI (16 subdevices)
hw:0,2	Emu10k1 Synth MIDI (16 subdevices)
hw:2,0,0	TRITON Extreme MIDI 1
hw:3,0,0	MidiSport 1x1 MIDI 1
hw:4,0,0	Keystation MIDI 1

I've tried sending data via the Keystation, the
MidiSport and the emu10k1 UART, nothing goes.

I can receive data just fine with the UART and
the MidiSport (the Keystation does not have a
MIDI IN, only an out.)

Getting the obvious out of the way:  the cables
have been checked and re-checked.  I've tried all
devices with jack running, jack not running, as
both regular user and root, no data gets sent.

The MidiSport has three LEDs on it that show MIDI
sync, MIDI data in and MIDI data out.  When I do
a sysex from the 64 and save data the MIDI in
flashes.  When I do a sysex to the 64, the MIDI
out does not flash.

The command I'm using is:

amidi -p hw:x[,x,x] -s sysexfile.syx
(for example "amidi -p hw:0,0 -s lastninja.msx" to
send from the UART (also tried just hw:0, ad nausium)

which worked fine on my old install of CCRMA.

As a test, I tried to send some patches to my
Roland D-20 and Korg DS-8 and I get the same
result:  no data gets transferred.

Also, regular MIDI works fine.  I'm able to
trigger M64 (and other devices) with a sequencer,
or by just plugging a MIDI controller straight in.
It's just sysex from alsa in planetccrma that's
not working.

Am I missing something?  Is there a reason that
the MIDI outs might be blocked?  As I said, I
tried it with both jack running and with jack
not running with the same results.

Once again, any information at all is appreciated,
and please feel free to point out obvious things
I may have missed.