[PlanetCCRMA] Pulling USB cable on FC2 machine causes keyboard and network to crash...

jim branagan ccrma@themusenashville.com
Sat Apr 2 02:06:01 2005


>>I think I've read of similar things happening (don't remember on which
>>list). Most probably a kernel bug.
>>    
>>
>
>OK. In that case where do I report it? (Assuming I try it again and
>the problem repeats...)  To Alsa's mantis site and let them deal with
>it? Someplace else?
>
>  
>
Is USB hotplugging supposed to work in linux?  I always assumed this was 
one of those rough edges we didn't have right yet.  I seem to be able to 
hotplug a keyboard or a mouse, but trying with a USB drive, digital 
camera or CD writer crashes, hangs, or causes other weird behavior.  
I've almost never tried to reproduce such behavior; in fact I generally 
avoid doing anything I'm afraid will crash the machine.  When I tried 
the camera and USB hard drive on a new FC3 installation, plugging in the 
USB drive or unplugging either the hard drive or the camera crashed the 
machine so hard there isn't even an oops in the logs. 

-- 
e. james branagan
the MUSE  Nashville, TN