[PlanetCCRMA] Enabling low latency in FC2

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Tue Sep 28 18:03:02 2004

On Tue, 2004-09-28 at 17:45, Mark Knecht wrote:
>    I want to check as to whether there are any system values I need to
> enable to get low latency and root level capabilities as a normal user.
> Currently I cannot start QJC as a normal user using jackstart as the
> start method. I can run QJC with jackd.

To run jackstart as you did under 2.4.x (as a non-root user) you need to
load a special kernel module (that is included in the Planet CCRMA 2.6.x
kernels). To get the same behavior as before do, as root:

  /sbin/modprobe realcap allcaps=1

The module has more options, for example, you can only enable users in a
certain group to be able to start realtime priority tasks. 

> I have the ll kernel running with Alsa 1.06. Unfortunately I
> have not set up access to email on the Planet side yet so it is
> difficult for me to provide output today. Hopefully I'll have that
> tomorrow.
> I have enabled the items in the email you directed me to:
> kernel_preemption == 1
> voluntary_preemption == 3
> threaded IRQ for the ATI chip == 0
> (It dawns on me right now that if these values didn't stick after my
> reboot that possibly one or more were not set. I'll check next time I go
> over.)

That's correct. 

> In rereading the email right now I see that the sysrq == 1 was not
> marked optional. Is that a requirement? I'll try that when I go back
> over also.
> Right now, even as root, if I run jack with moderate latency settings of
> 512/2 using my USB mouse is causing lots of xruns so clearly something
> is not right.

I have not tried usb mice so it may be a problem in that area with the
voluntary preemption patches. I assume you were running as root and
using jackd -R, otherwise all bets are off. 

> As a normal user QJC tells me the kernel doesn't provide capabilities so
> clearly somethign seems like it needs enabling.

If you load realcap as outlined previously you should be able to run
"jackstart -R ..." as a normal user. 

> I may try your xrun logging feature and see what it tells me.

-- Fernando