[PlanetCCRMA] Planetedge Q3

Janina Sajka janina@rednote.net
Wed Sep 22 14:49:01 2004

Hi, Matt:

Thank you for posting about your X86_64 progress.

Just thought I'd pipe up to say that I'm also working on putting
together a dual Opteron box with SATA drives, though my controller is
the 3Ware 9500. It has worked like a charm with my 5 WD drives.

I've had my problems, only some of which are resolved. memtest
identified a bad RAM stick. Now that that stick is out of the box this
machine is amazingly stable (as one would expect a Linux system to be).

However, my Fedora dev kernel (2.6.8-1.541) does not see the PCI
interface to my RME Multiface. The closest I come (via lspci -v) is:

I'm actually wondering whether anyone else has one of these cards in an
x86_64 box?

Subsystem: Adaptec: Unknown device 005e

Trying to run hdsploader seg faults.

I have also not succeeded compiling the CCRMA kernel on this box.

Matt Barber writes:
> Hi,
> I thought some of my experiences with the Q3 planetedge kernel might be
> helpful.
> We built a new dual-opteron box with sata (silicon image controller and
> western digital drives).  Fedora installation was very smooth.  After
> that, though things got a little rough.  We first tried x86_64 fedora,
> but I wasn't able to rebuild the ccrma kernel for x86_64 architecture (I
> didn't try that hard, as I was going to wait until x86_64 becomes more
> of a factor, and Fernando has some 64-bit ccrma kernels).... anyway, so
> after the second installation, I installed both the P9 and the Q3
> kernels, neither of which were able to find the sata drives. I
> wasn't sure the initrd was doing its job loading the modules, so I tried
> compiling sata support for the sata controller into the kernel, which
> for some reason didn't work either.  My final solution (though not quite
> kosher) was to hold on to the sata_sil module from a normal rebuild,
> rebuild with sata support in the kernel, install and then copy the
> module into the /lib/modules directory for that kernel, and then run
> mkinitrd (leaving the sata line in modprobe.conf) so that the module was
> part of the ramdisk.  This seems to have worked, as I can now boot with
> ease.  Overall, the system seems to work better with acpi off, and I'm
> not sure how apic irqs work, but the delta 1010 we were using was
> putting itself on irq 27 until I added noapic to the kernel arguments.
> Jack, once it is up and running, seems to do amazingly well (using jack
> by itself doesn't produce the hard system locks people have described
> with smp systems).  However, some things (like cdrdao) seem completely
> incompatible with the realcap module.  If I start burning a cd with
> realcap on, it locks the system... cd burning doesn't work with acpi,
> either.  So far it is possible to burn using sudo (error messages
> without sudo - a 2.6.8* thing?), and I'm curious whether it is sudo jobs
> that react badly with realcap rather than cd burning... I should test
> that more.  I also have not tried k3b yet.  When is the newest ccrma
> kernel scheduled to come out (no pressure at all, but I need to know
> whether I should try to get things working on this one if the newest one
> has some potential fixes in it, since we are of course itching to get
> this box up, and I could save time rebuilding and tinkering if there is
> a fix for some of these problems in the newest kernel)...
> One other annoying thing, that I suspect is related to the nvidia
> driver, is that when I log out of gnome, it sometimes freezes x, so that
> I have to ctrl-alt-backspace to get where I can sign in again.  Does
> this happen to anyone?
> Thanks for everything - I'm really pleased by the progress in 2.6.
> Matt
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA@ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma

				Janina Sajka, Chair
				Accessibility Workgroup
				Free Standards Group (FSG)

janina@freestandards.org	Phone: +1 202.494.7040