[PlanetCCRMA] Re: jack_fst - Library requirements

Matthew Allen matthew@lith.com
Thu Oct 28 15:21:02 2004


> -----Original Message-----
> From: Mark Knecht [mailto:markknecht@gmail.com] 
> >         I got plain old fst-1.6 to compile and install just fine (I 
> > had to cp mkinstalldirs from the jack_fst directory over). However 
> > when I go to ./configure jack_fst-1.2 it craps out on gtk+. I am 
> > running CCRMA FC1 (downloaded and installed on Tuesday). With this 
> > version of CCRMA I am looking at gtk 1.2.10. If I get the rpms for 
> > gtk+-devel the amount of dependencies is insane. Basically 
> it wants me 
> > to upgrade gtk+ and pretty much 75% of my current CCRMA 
> apps seem to use it.
> OK, first you do have to make & install fst first, so that's cool. 

Yeah that went great and was easy.

> Second, I am running either Gentoo-2.6.9 or FC2 when I do any of this.
> I don't know what the dependencies are for jack_fst, or why 
> FC1/RH9 wouldn't be enough, but time marches forward and 
> developers sometimes grab stuff that's new.

I think FC2 actually comes with gtk 2.0 or greater (it comes with the
gimp 2.0 I think, which means its GTK has to be greater than 2.0) so I
don't think you had to deal with this issue. 

> I would presonnally say that even if apt wants you to upgrade 
> 75% of your FC1 installation, at least you are PlanetCCRMA 
> based which makes it about the safest update I know how to 
> do. My inclination would be to put myself in Fernando's 
> capable hands and let apt or synaptic take over. I expect 
> that when you've done that everything will be just fine.

I totally agree, except that the gtk and gtk devel on the planet are too
old for jack_fst and so if I want to use it I need to upgrade from
source or external rpm, and at that point I get a little worried cuz I
don't want to break my planet!

Is everyone else who has succesfully installed fst and jack_fst running
under FC2?