[PlanetCCRMA] Re: 2.6.7 ccrma kernel and usb / nvidia support

Shayne O'Connor forums@machinehasnoagenda.com
Wed Nov 17 17:12:00 2004

> >ok, well i'd decided to download the fedora core 1 ccrma
> distribution,
> >but discovered most of the iso's were corrupted (you might want to
> check
> >their integrity - though it's probly just my incompetence that let to
> >their corruption), so i was a bit defeated by that, and just decided
> to
> >stick with standard fedora core 2 2.6.5 kernel. but i kept the ccrma
> one
> >on there, just in case i got the guts to screw around with it again.
> >which i did ... and for some reason, the nvidia driver compiled
> against
> >the 2.6.7 kernel - booting into it, it showed the nvidia splash
> screen,
> >and instead of freezing, continued to boot! in disbelief, i plugged
> in
> >my zen touch to the usb, fired up gnomad2, and lo and behold, it was
> >detected, and could scan the songs on the player, and also transfer
> >songs to it!!! everything was working perfectly!!!!
> >then, for no reason at all, i one day booted into the ccrma kernel
> >(which was, by now the default) and ... it froze again, just after
> the
> >nvidia splash screen, where it says "Setting hostname". Grrrr. So I
> >reinstalled everything again, thinking "freakin 3D acceleration! who
> >needs it?!". i mean, it would be nice, but i don't really need it -
> so
> >that's not the issue, anymore really.
> A clue might be whether or not the zen is plugged in when booting.
> Maybe booting with it unplugged works? Then plug it in...

Well, I tried this, but same result ....

Is there any chance it could have something to do with installation of
jack? i'm sure i was thinking at one stage that it seemed to go bunk any
time config files were changed (like when jack installation adds to
fstab) ...

i probly should have mentioned before that the creative zen touch is not
a usb mass storage device - i mean, it doesn't show up as another hard
drive or anything - it uses proprietary drivers, but there is a linux
hack, using the libnjb library and gnomad2 (or one of several other
gui's) that allows it to work in linux. except on this 2.6.7 kernel ...
well, it HAS worked on here, but lord knows how that happens ...

i've posted to the libnjb lists, but no response as yet ...

anyone else?