[PlanetCCRMA] Re: 2.6.7 ccrma kernel and usb / nvidia support

Shayne O'Connor forums@machinehasnoagenda.com
Wed Nov 17 03:10:02 2004

ok, well i'd decided to download the fedora core 1 ccrma distribution,
but discovered most of the iso's were corrupted (you might want to check
their integrity - though it's probly just my incompetence that let to
their corruption), so i was a bit defeated by that, and just decided to
stick with standard fedora core 2 2.6.5 kernel. but i kept the ccrma one
on there, just in case i got the guts to screw around with it again.

which i did ... and for some reason, the nvidia driver compiled against
the 2.6.7 kernel - booting into it, it showed the nvidia splash screen,
and instead of freezing, continued to boot! in disbelief, i plugged in
my zen touch to the usb, fired up gnomad2, and lo and behold, it was
detected, and could scan the songs on the player, and also transfer
songs to it!!! everything was working perfectly!!!!

then, for no reason at all, i one day booted into the ccrma kernel
(which was, by now the default) and ... it froze again, just after the
nvidia splash screen, where it says "Setting hostname". Grrrr. So I
reinstalled everything again, thinking "freakin 3D acceleration! who
needs it?!". i mean, it would be nice, but i don't really need it - so
that's not the issue, anymore really.

after reinstallation, i tried to connect my zen touch with gnomad2 -
once again, i got the "no jukeboxes found on usb bus". grrr. so i
thought "ah, well - at least i can boot into the 2.6.5 kernel and it
works". so i did that. but a bit later, i decided to try plugging it in
again - and it worked!!! god knows why ... 

... then nvidia updated their driver, and i thought "hmmm, maybe this
one won't freeze my computer" - but, of course, it did ... and after
uninstalling it  .... "NO JUKEBOXES FOUND ON USB BUS"!!!!!!!!!


i'm happy with the 2.6.7 kernel and the audio applications i'm now able
to use with it - it's been a long struggle to get here.

i can do without 3d acceleration - i accept this now, and ain't even
going to bother, no matter how compatible the drivers get.

i CAN'T do without the usb access to my creative zen touch - obviously
it CAN work on the 2.6.7 kernel, but only in what (to me) seem totally
arbitrary conditions.

Fernando - i don't know how to get any other error message than the one
that gnomad2 gives "No jukeboxes found on USB bus" ... as they say "i'm
totally new to Linux" ... could you point me to the shell commands i'd
have to type to get diagnostic information of the sort that would help
to solve why 2.6.7 is not recognising my device? as i said before, if i
boot up the default 2.6.5 kernel - it detects the creative zen touch
perfectly ...

please help


> On Tue, 2004-11-02 at 11:27, Shayne O'Connor wrote:
> > but blast! of course this success broke some other very important things
> > - libnjb (library for creative nomad jukeboxe support) and nvidia 3d
> > capabilities. when i fire up gnomad2 (front-end for libnjb) it says it
> > can't find anything on the usb bus, but if i switch back to the stock
> > fedora core 2 2.6.5 kernel, it works fine. is the newer kernel blocking
> > user access to usb bus?
> Not that I'm aware of. Could you send the exact messages you are seeing?
> > when i installed the nvidia driver and changed the xorg.conf, every time
> > i reboot the computer freezes just after booting the kernel image. i've
> > read about the 2.6.7 kernel having 4-stacks or something option that
> > kills nvidia driver - i've searched atrpm's for a kernel-module, but
> > there is none for this version of the kernel.
> I think the latest nvidia drivers work with 4k stacks in 2.6.x kernels.
> Are you using the latest version? I seem to remember somebody on the
> list saying that they had managed to get it working. 
> -- Fernando