[PlanetCCRMA] ntfs module fc2

Anders Vinjar andersvi@extern.uio.no
Tue Nov 2 01:05:21 2004

Thanks for the hints, which helped solve problem with the missing
ntfs-module on the 2.6.7-1.437 kernel from ccrma.

Didnt find any Makefile to change EXTRAVERSION in.  I see theres
a reference in ./build-2.6 to EXTRAVERSION somewhere which might
be used.

What solved it was as simple as renaming the src.rpm from ccrma
to match the output from `unama -a`.src.rpm.  Using the following
commandline to build the ntfs-module:

./build-2.6 kernel-module-ntfs.spec kernel-2.6.7-1.437.1.ll.rhfc2.ccrma.src.rpm i686

- which made installing the ntfs module go straight through (so
now people can continue to supply me with files on ntfs-formatted

Thanks alot!

>>> "f" == fonse  <fonse006> writes:
>> ===== Original Message From Anders Vinjar <andersvi@notam02.uio.no> =====
>> I have some trouble getting support for ntfs in the kernel im
>> running.
>>> uname -a
>> Linux localhost.localdomain 2.6.7-1.437.1.ll.rhfc2.ccrma #1 Thu Jun 17 
f> 10:45:42 PDT 2004 i686 i686 i386 GNU/Linux
>> There wasnt any ntfs support in the kernel, and no downloadable
>> rpm fitting the kernel from the linux-ntfs site at sourceforge.
>> Tried building my own with the kernel.src from PlanetCCRMAs
>> SRPMS/*, and everything went right with building and installing
>> "rpm -ivh" of resulting package.
>> However /sbin/modprobe ntfs returns an error:
>>> /sbin/modprobe ntfs
>> FATAL: Error inserting ntfs 
f> (/lib/modules/2.6.7-1.437.1.ll.rhfc2.ccrma/kernel/fs/ntfs/ntfs.ko): Invalid 
f> module format
>> Any clues?
f> I am not sure if you still need an answer to this, I was out of town for 
f> Halloween, but here goes.  The problem that you are having is likely do the
f> EXTRAVERSION in the makefile being set wrong.  After you do make xconfig or 
f> menuconfig or whatever you need to edit 
f> /usr/src/linux-2.6.7-1.437.1.ll.rhfc2.ccrma/Makefile to match the kernel you 
f> are running. 
f> make the modules. Then add ntfs.ko to your modules directory.
f> You should then run depmod I am not sure if you are doing that.
f> then modprobe.  I have not tried this with a 2.6 kernel because I have no 
f> need, but this worked with the 2.4 kernel. I hope this helps.
f> Adam
>> Is there a downloadable rpm for ntfs-support on this kernel
>> somewhere at ccrma?
>> Is there ntfs support built in in any later kernels (fc2)?