[PlanetCCRMA] Can't start Jack/Alsa

Mark Knecht mknecht@controlnet.com
Wed May 19 14:57:01 2004

Nathan Hale wrote:
> Hi,
> When I try to start jack/alsa, I get this output:
> JACK compiled with System V SHM support
> loading driver ..
> apparent rate = 44100
> creating alsa driver ... hw|hw|1024|2|44100|0|0|nomon|swmeter|rt|32bit
> jackd: pcm.c:690: snd_pcm_nonblock: Assertion `pcm' failed.
> Aborted
> Any thoughts?
> Thanks,
> Nathan

    I've had this problem quite a lot recently. In my case the actually 
driver for the card wasn't getting loaded. When Alsa is running, but 
there is no card driver, I got this message. modprobe snd-atiixp by hand 
solved this problem. However, once I've made the mistake of trying to 
start Jack without a card driver running the only solution I've found is 
to completely reboot, load the driver and then start Jack. Likely 
there's a better way, like deletign some special JAck FIFO file or 
something, but it's not easy to find documentation so that's what I was 

    I have since rebuilt my kernel with the Alsa sound card driver built 
into the kernel instead of as a module. This solved the problem for me, 
but I don't recommend that it's the right way to go.

Good luck,