[PlanetCCRMA] Can't get Jack to start

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Sun May 16 11:50:02 2004

> I have a dual AMD MP 2800 system running Fedora Core 1.  Right now I'm
> only using the onboard soundcard (I'll probably move to something like a
> Turtle Beach Santa Cruz later), an Intel i810_audio chipset.  I can play
> music fine using the Music Player app, but I can't seem to get Jack
> started.  I used the following command:
> Jackd -alsa
> I then get this message:
> loading driver ..
> creating alsa driver ...
> hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|rt|32bit
> jackd: pcm.c:687: snd_pcm_nonblock: Assertion `pcm' failed.
> Aborted

It looks like alsa is not running..

> Jack was installed as I installed Ardour, with the command apt-get
> install ardour.
> I'm not using the Planet kernel; first of all I tried it with this but
> with the same result, and secondly because I would like to take
> advantage of the SMP that came with Fedora. 

First, you have to have alsa kernel modules that match the kernel you
are booting. So, if you are booting the original rh or fc kernel and you
have not rebuilt the alsa driver for them then you don't have them and
they will never load :-)

Also, the Planet CCRMA kernel has an SMP version as well, that kernel
will use both cpus in your computer. See the installation instructions
(you have to "apt-get install planetccrma-core-smp"). 

> I Googled this and heard
> something about this being caused by the Alsa modules not being loaded? 
> I'm pretty familiar with Linux, but am a bit of a noob when it comes to
> kernel modules...  If it helps any, here is the output of the lsmod
> command:
> Module                  Size  Used by    Tainted: PF
> i810_audio             28264   1  (autoclean)
> ac97_codec             16876   0  (autoclean) [i810_audio]
> soundcore               7108   2  (autoclean) [i810_audio]

You only have OSS loaded. 
Have you followed the instructions on configuring ALSA on your computer?
It will not work by just installing the packages (it is not that easy

What are the contents of /etc/modules.conf?
-- Fernando