[PlanetCCRMA] ALSA: Cannot restart alsa - FC1 - ICE1712

Brian Arsenault barsenault@gto.net
Thu May 6 10:55:02 2004

Hello everyone,

I am somewhat new to the list, but have been lurking for a while.  I've
recently installed the PlanetCCRMA audio packages on FC1 and have a bit of
problems with alsa.

Alsaconf runs correctly, and finds my Delta 44 (ICE1712.)  It modifies my
/etc/modules.conf with the correct settings as far as I can tell.

The first time I did this, it worked fine.  However when I reboot, no sound.
So I try to /etc/init.d/alsasound restart.  This fails reporting _Device or
resource busy_ for each associated module.  Of course rmmod does not work
either, returning the same error.

I've tried ps -aux grepping for anything _sound_ related, but cannot find
anything.  Kudzu is not running so I don't think any OSS stuff is loaded.
Certainly nothing OSS related is showing up with a lsmod.

If I remove the Alsaconf portions of /etc/modules.conf, reboot, and re-run
alsaconf, it will work, until I reboot the next time repeating the behaviour
expressed above.

Unfortunately I am not in front of the machine right now so can't include
the exact error messages, but any suggestions are appreciated.  I can
subsequently follow-up with specifics a little later.