[PlanetCCRMA] Upgrade report

Joseph Dell'Orfano fullgo@dellorfano.net
Tue May 4 18:59:01 2004

Well, I decided to u/g from my excellent and very stable RH 8.0/CCRMA
machine to fedora core 1/CCRMA. Why do this? The 8.0 worked so well, I
needed something to do! Also, I couldn't get dual Radeon cards to work
under RH 8.0 which I suspect is because of the version of XFree I was
using. Dual display works beautifully well. The upgrade was a bit

I used fedora distribution disks and selected the upgrade option, which
seemed to go well. Next (following CCRMA instructions, as always) I
downloaded the appropriate version of apt. This required that I rpm -e
my previous version, which in turn requires rpm -e of the old synaptic.
Once this was done, apt-get reported broken alsa-kernel modules (from
CCRMA 8.0). I manually removed all of the packages with rpm -e, which
was a tedious operation. Once cleaned up, however, all went well.

After the RPM hell, I found that I needed to apt-get prelink in order to
get jack to work. After this, all of the audio stuff worked well.
Cinelerra remained broken, and I had to do apt-get remove tap-plugins. I
guess Cinelerra doesn't like these plugins. I also found that when I
tried to load a previous project, Cinelerra immediately crashed with a
segmentation fault. I was able to finally load the file on another
fedora workstation, rename it and then load it on my new CCRMA install.

Now, I am happy to report that everything is working as good as my old
RH 8.0 system, so I'm looking forward to a new install so I can break it

What have I learned from this?

1. Perhaps it would've been best to apt-get remove my CCRMA stuff from
RH 8.0 prior to the u/g

2. apt-get install prelink

3. apt-get remove tap-plugins

4. Pray

I hope this helps. If there was anything that I did that was stupid, I
would appreciate the feedback!! And thanks again Fernando for an
outstanding job with the Planet.

-Joe Dell'Orfano