[PlanetCCRMA] FC1 and 1394 at boot time

Mark Knecht markknecht@comcast.net
Mon Mar 22 18:11:02 2004

On Mon, 2004-03-22 at 17:37, Fernando Pablo Lopez-Lezcano wrote:
> > Just an FYI. I shoehorned a copy of FC1 onto my work Gentoo box this 
> > morning. 1394 doesn't boot on this box with any of 3 different 1394 
> > controllers I've had a chance to try in it, so I think the laptop issue 
> > that was mentioned here the other day isn't specific to Sony's OHCI 
> > controller.
> What is it that happens? The boot hangs? I currently have FC1 running on
> my laptop and it seems to be happy (ie: no hangs and a complete boot). I
> don't currently have a ieee1394 device to test with...
> -- Fernando

On this machine I worked on today the installation kernel installed 1394
just fine, but when I tried to boot the machine it got to the point
where it said it was loading the 1394 drivers and then just hung. I
modified the grub kernel line to add nofirewire and the FC1 kernel
booted fine then.

To be clear, this is not your kernel but rather the default kernel
installed by FC1 which I had not used before. (Something like
2.4.22-1.ntpl.2115? That's from memory though....)

It might not happen with your kernel. I don't know. I just remembered
you saying something the other day about Sony laptops having troubles so
I thought I'd mention it's not just portables.

Once the system is booted I can modprobe the 1394 drivers in a script
file just fine.

- Mark