[PlanetCCRMA] terminatorX and liblrdf

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Mon Mar 15 15:22:02 2004

> > > after some PlanetCCRMA upgrades on Fedora I tried to use terminatorX 
> > > (worked fine before) and got an errormessage:
> > > something like cannot locate "liblrdf.so.0"
> > > i made a link to liblrdf.so.2 in /usr/lib
> > > and it worked fine again, 
> Fernando, I ran into this recently too - my most recent build of Ardour
> for the first time failed, wanting liblrdf.so.0.  linked to 
> /usr/lib/liblrdf.so and all was well, but this was the first time I've seen
> this.

Which version of liblrdf did you have installed at that time? (if you

> Aside from Ardour, I install everything on this system using 
> Synaptic to fetch the upgrades from the Planet's repositories.
> There were no files of the format /usr/lib/liblrdf.so.n on my system.

That is very strange, you are just using Planet CCRMA packages? This was
the old version:

# rpm -q -l -p liblrdf-0.3.4-1.rh90.ccrma.i386.rpm |grep so

# rpm -q -l -p liblrdf-devel-0.3.4-1.rh90.ccrma.i386.rpm |grep so

and this is the current version:

# rpm -q -l liblrdf|grep so

# rpm -q -l liblrdf-devel|grep so

So, the .so.* files should have been there. If you are compiling you
should install the liblrdf-devel stuff, maybe you were missing that?
(but then your ardour build should have failed). 

> > What does "apt-get check" say? You should have broken dependencies, I
> > think. 
> I've got no broken dependencies, and my liblrdf's are at:
> liblrdf-devel-0.3.5-1.rh90.ccrma
> liblrdf-0.3.5-1.rh90.ccrma
> > You don't need, and should not have, the link you made in /usr/lib (to
> > the .so.0 library). You need the proper terminatorX that is linked
> > against the latest liblrdf. 
> Perhaps I should be asking the Ardour developers about this, but it seemed
> too coincidental to me, so I thought I'd mention it.

Maybe you have more than one liblrdf installed? Check in /usr/local just
to make sure that you don't have anything extra there. The mismatch
could happen if the header files ardour is seeing are for liblrdf <
0.3.5, then it would complain later when it cannot find the shared
libraries (because they have a different so version in >= 0.3.5).

Thanks for the report...
-- Fernando