[PlanetCCRMA] terminatorX and liblrdf

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Sun Mar 14 11:19:00 2004

> after some PlanetCCRMA upgrades on Fedora I tried to use terminatorX 
> (worked fine before) and got an errormessage:
> something like cannot locate "liblrdf.so.0"
> i made a link to liblrdf.so.2 in /usr/lib
> and it worked fine again, although only TAPs-plugins are classified the
> right way all other plugins remain unclassified...hmm
> maybe its just something with my personal setup...

Are you using apt for the upgrades? They should have pulled in all the
proper versions... It would seem you have an old terminatorX (built with
liblrdf < 0.3.5) but the new liblrdf installed (= 0.3.5). What is the
version of terminatorX? The latest you should have is:
(do a "rpm -q terminatorX" to find out). 

What does "apt-get check" say? You should have broken dependencies, I

If you have anything less than the current version "apt-get install
terminatorX"... You should also check what liblrdf you have (should be

You don't need, and should not have, the link you made in /usr/lib (to
the .so.0 library). You need the proper terminatorX that is linked
against the latest liblrdf. 

-- Fernando