[PlanetCCRMA] Re: [PD] [OT] RME Install Help

thomas gorbach thomas.gorbach@t0.or.at
Thu Mar 11 00:12:02 2004

thewade schrieb:


I also had the pcm error when i started pd with the rme card.

What i did:

after starting the machin i did not login but first run alsaconf from 
the first consol as root. The rme card needs to have store first. After 
configuring the card i did login. Next start jack and then pd. Now use 
the sound and midi configuration and pd is running.

Thats the way i got pd running.
Hope that is helping you.


> Firstly, thanks for the help!
> Heir Barknecht hat gesagt:
>>>Question one: I have make install-ed alsa 1.3a drivers, do I have to
>>>rebuild my kernel, as alsa is now built into the kernel in 2.6?
>>2.6.3 comes with ALSA 1.0.x inside. I don\'t know which, but you
>>shouldn\'t need to upgrade. If you still want newer ALSA drivers, then
>>build the kernel without alsa, check out ALSA cvs and \"./configure
>>--prefix=/your/kernel-2.6.3/path && make install\" it
> Ok, so when I build the driver with kernel = linux 2.6.3 its not updating the kernel source? So ill just go with the linux alsa then... I still run alsasound from init.d, right, despite the drivers being in the kernel?
>>>Question two: I get this error with pd and the multiface
>>>using non-interleaved audio input
>>>Sample width set to 4 bytes
>>>snd_pcm_hw_params_set_access (output): Invalid argument
>>>using non-interleaved audio
>>>pd: pcm.c:1133: snd_pcm_readi: Assertion `pcm->access == SND_PCM_ACCESS_RW_INTERLEAVED\\\' failed.
>>>Pd: signal 6
>>Does Jack work? Does Pd work over Jack?
> Yes and no. I get no errors, but audio doesnt work. When I test audio and midi, and send midi out, the midi light flashes on the multiface, and when I run hdsploader, the host error light goes away.
> Its not that I get clicking or intermittent sounds of any kind, I just get deas silence...
> My audiodev is set to 3, but my /proc/asound/cards has just 0 -> maestro3 and 1 -> hdsp. Through experementation I found that the -alsa flang in conjunction with -audiodev 3 references the hdsp.
> I ran this:
> [wade@transport wade]$ sudo jackd -R -d alsa -d hw:1 -r 48000 -p 2048
> jackd 0.94.0
> Copyright 2001-2003 Paul Davis and others.
> jackd comes with ABSOLUTELY NO WARRANTY
> This is free software, and you are welcome to redistribute it
> under certain conditions; see the file COPYING for details
> JACK compiled with System V SHM support
> loading driver ..
> apparent rate = 48000
> creating alsa driver ... hw:1|hw:1|2048|2|48000|0|0|nomon|swmeter|rt|32bit
> control device hw:1
> configuring for 48000Hz, period = 2048 frames, buffer = 2 periods
> [wade@transport wade]$ sudo pd
> reading startup file: /home/wade/.pdrc
> priority 98 scheduling enabled.
> memory locking enabled.
> priority 96 scheduling enabled.
> memory locking enabled.
> couldn\'t open MIDI input device 0
> couldn\'t open MIDI input device 2
> couldn\'t open MIDI output device 0
> couldn\'t open MIDI output device 2
> opened 1 MIDI input device(s) and 1 MIDI output device(s).
> PDP: pure data packet
> PDP: version 0.12.3
> PiDiP : additional video processing objects for PDP : version 0.12.13 ( ydegoyon@free.fr )
> [wade@transport wade]$ cat .pdrc
> -jack
> -rt
> -lib /usr/local/lib/pd/externs/pdp
> -lib /usr/local/src/pidip-0.12.13/pidip 
> -path /usr/local/src/pidip-0.12.13/patches
> -path /usr/local/src/pidip-0.12.13/doc
> -path /usr/local/src/pidip-0.12.13/fonts
> -path /usr/local/lib/pd/externs
> -mididev 1,2,3
> -r 48000
> -sounddev 3
> -blocksize 2048
> -channels 18
> -audiobuf 8
> _______________________________________________
> PD-list mailing list
> PD-list@iem.at
> http://iem.at/cgi-bin/mailman/listinfo/pd-list