[PlanetCCRMA] added: ALPHA version of Planet Core components for FC2

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Sun Jun 20 19:37:00 2004

On Sun, 2004-06-20 at 13:31, Steve Harris wrote:
> I just tried with the new jackd (but without the anti-storm patch) and it
> didn't seem much better.

It does make a difference in my case. Well, I have not tested recently,
maybe it does not :-)

> I was using jackstart BTW, is that right? 

Yes, that is the way I'm starting it. You have to load the realcap
module before starting jack, maybe that is missing? I do it like
"/sbin/modprobe realcap allcaps=1" (this gives you the same behavior as
2.4.x with the capabilities patch), or you can use the init script
that's on the web site. 

> Or is there some other way to
> get the realcap stuff going? I'm not convinced that it was running in RT,
> the RT light didn't come on in qjackctl when I tried that, but I didnt get
> the error messages when I tried from the command line.

Well, when I was having the problem with the realtime thread creation
pthread_create was not creating it SCHED_FIFO _but_ it was not returning
an error. I would presume that it should...

You can check the scheduler of all the threads with chrt (part of the
schedutils package). "chrt -p pid" will tell you which scheduler is
being used. The output of ps will not show all threads, use the main
thread from ps and look up all the others in /proc/xx/task/, where xx is
the pd of the main thread. 

Let me know how it goes. 
I don't think I will have a chance to test your patch till tomorrow. 
-- Fernando