[PlanetCCRMA] Oxygen 8 and Fedora CCRMA ???

Simon Schampijer Simon.Schampijer@ircam.fr
Mon Jun 7 01:39:01 2004

On Fri, 2004-06-04 at 13:49, luigi rensinghoff wrote:
> hi all !!
> Hi to all !
> I wonder if someone might invest some time to help me
> getting my oxygen 8 usb midi Keyboard Controller to
> run under Planet CCRMA Fedora package.
> Here's the little story:
> It took me about half a year to get my setup running
> on a Linux desktop machine. I gathered some experience
> with Planet CCRMA RH 8 and got it all running. I am
> really not a linux expert so things like applying
> patches and recompiling kernels cause some headache to
> me.
> Somehow it was really easy to get the oxygen 8 running
> under CCRMA RH 8, but i dont really remeber how i did
> it. 
> Now i switched to Fedora CCRMA and it does not seem to
> be as easy.
> I found some howtos (Ircam/Alsa/ccrma) but they dont
> really work for me i always get a PE header error when
> i try to load the firmware. Then suddenly yesterday
> when i ran hdsploader ( I am using a HDSP Hammerfall +
> Multiface) the device appeared for about an hour ;-)
> But i couldnt reproduce it. 
> so what i need is a little bit more understanding an
> maybe an advice what i should do.
> I wonder if everything is going to be easier with
> kernel 2.6 (Is it in planning for Planet CCRMA ??)
> The combination of hotplug fxloader ezusbmidi is quite
> confusing to me, i dont exactly in which directories
> to see to do step by step troubleshooting.
> Well, of course i you can just help me with ONE of my
> numerous questions i would be very happy.
> Best Regards Luigi

Hi Luigi, 

I have got following Setup:

FC1 with oxygen8

used this Guide for the midi usb interface installation

(I didn't do the extract with the latest version...hadn't this error
-> a PE header error )

If all worked out properly -

- watch out for your cards :
    cat /proc/asound/cards

if the oxygen is on the 0 Index
add this to the /etc/modules.conf

   alias snd-card-1 snd-usb-audio
   options snd-usb-audio index=1

and maybe you want to do the following to
add the module to the hotplug blacklist (I don't know
if this really made a difference in my setup -
seemed to work after rebooting without adding this
, hmm don't know yet why -> have to check that)

Hope this helps ->

Best Regards


> __________________________________
> Do you Yahoo!?
> Friends.  Fun.  Try the all-new Yahoo! Messenger.
> http://messenger.yahoo.com/
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA@ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma