[PlanetCCRMA] Getting sound to work in Rosegarden-4

Luc Tanguay lucus@sympatico.ca
Wed Jul 21 19:05:02 2004


you need to load soundfont onto your audio card.  With my audigy, I do 
have the following instruction in my /etc/modules.conf:

post-install snd-emu10k1 /bin/sfxload -V100 /disk2/m/soundfonts/CT4MGM.SF2

Hope this help,

jsdey@optonline.net a écrit :

> Hi Shelagh:
> I didn't go far enough explaining my set up.  I have a  SBLive sound 
> card.  I tried the -iA option
> in timidity and it said the option was not compiled in.  I can play 
> midi file from timidity though.  Thanks for
> your help.  Maybe someone else will have some additional suggestions.  
> Still no sound from Rosegarden.
> John
> On Jul 21, 2004, at 6:08 PM, Shelagh wrote:
>> As I had a similar problem a few weeks ago, I thought I'd let you 
>> know what
>> my solution was. The symptoms you describe are as if your sound card 
>> is somethng
>>  like the SB128 or some other soundcard which does not have onboard 
>> midi wavw table
>> This means that you wil need to run Qsynth to load the sound fonts as 
>> a separate
>> process. In windows the soft synth comes as part of the operating 
>> system, but Linux
>>  does not have this. You nees to load a soft synth such as Timidity 
>> (using the -iA flags ) or
>> qsynth. One cavet, if your computer is slow (like mine) you might 
>> have to get another sound card
>> which does have onboard midi. eg SBLive! or a proper midi card such 
>> as the M-audio series.
>> Slow computers can't run Jack, Qsynth and rosegarden at the same 
>> time. 800mz and above should
>> be all right
>> Hope this is useful to you.
>> Shelagh
>> On Wed, 21 Jul 2004 15:28:57 -0400, <jsdey@optonline.net> wrote:
>>> Hi all,
>>> I am running RHC1 kernal patches and alsa installed.  I am letting 
>>> rosegarden start jackd which it does.
>>> I used the same parameters that comes with the stock installation 
>>> except the I needed to change the
>>> directory to point to jackd.  I cannot get the sound to play back 
>>> from rosegarden although the bar passes over the score.
>>> I did run
>>> ecasound -f:32,1,48000 -i null -o jack_alsa,myport -b:1024 
>>> -el:sine_fcac,440,1 from the shell and that works.
>>> I can export a file in midi and play it externally using timidity.  
>>> Any thoughts on how I might proceed running
>>> down the  problem will be greatly appreciated.  Thanks
>>> John
>>>   _______________________________________________
>>> PlanetCCRMA mailing list
>>> PlanetCCRMA@ccrma.stanford.edu
>>> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA@ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma