[PlanetCCRMA] AC97-ICH5 onboard sound stopped working after upgrade to 2.4.20

Pablo Varela pablo@pabloylola.com
Wed Jan 14 12:41:01 2004

 --- Fernando Pablo Lopez-Lezcano <nando@ccrma.Stanford.EDU> escribió:
> > I have a Gigabyte motherboard with AC97 sound on it. I had it
> working
> > under kernel 2.4.20-18.1.capssmp and the corresponding alsa modules
> > using the module snd-intel8x0.o.
> > 
> > After upgrading to 2.4.20-24.1.capssmp.rh90.ccrma the sound stopped
> > working. The driver seems to load OK and I've tried every possible
> > combination with alsamixer and gamix but I couldn't get sound
> through
> > the line-out connector.
> Weird. Did the upgrade include a newer version of alsa? That might be
> the problem. You could try erasing /etc/asound.state and starting the
> alsamixer or gamix configuration from scratch. 

Yes. The update changed ALSA from 0.9.4 to 1.0.0rc2.

I tried everyting I can imagine withthe mixers (including erasing the
asound.state file and doing manual changes to it) to no avail.

I've seen other postings (on this list or in alsa-user, I don't
remember) where people with other motherboards that seem to have the
same sound chipset are experiencing the same problems. I guess someone
did a change to the module and "broke" it.


Yahoo! Messenger - Nueva versión GRATIS
Super Webcam, voz, caritas animadas, y más...