[PlanetCCRMA] Re: a note for Fedora Core 1 users

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Mon Jan 12 17:16:02 2004

> > I don't think my apt is that new. Using rpm alone in RedHat *.* (no apt)
> > "rpm -Uvh" of a package that had an Obsoletes would replace the
> > obsoleted package with the new one. That does not seem to happen anymore
> > in FC1 (again, using only rpm, no apt). I'll test again to make sure but
> > that is what I was seeing in my FC1 machine. 
> You mean that is already happening on rpm level? That would be a
> severe bug!

Yes, so I thought I had to be making a mistake. 

So I tried again and it works, although the newer apt behavior seems to
be different that the older apt (that I still have in RHx.x). If I
include the "Conflicts:" tag apt fails saying it can't install because
of the conflict (but rpm alone installs it). It would seem it does not
realize that the package will be erase and thus it will _not_ conflict.
If I only add the "Obsoletes:" tag things install fine. I have no idea
what I did wrong last week, I'm pretty sure I tried this...

Anyway, "Obsoletes:" alone is not (IMHO) enough as it does not make it
impossible to install the differently named package (the "Obsoleted"
one) later. That is why I needed to add the "Conflicts:" tag as well.
The combination does work with the apt version I have on RHx.x. 

-- Fernando