[PlanetCCRMA] Fluidsynth can't talk to JACK

Peter Howard pjh@coastal.net.au
Thu Feb 19 20:59:01 2004

Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

On Fri, 2004-02-20 at 14:12, Fernando Pablo Lopez-Lezcano wrote:
> > This is on FC1.  jack 0.94, qjackctl 0.2.5, fluidsynth 1.0.3, and qsynt=
> > 0.1.0
> >=20
> > I use qjackctl to start jack, then qsynth to start fluidsynth.  But I
> > keep getting the following error out of qsynth:
> >=20
> > "Failed to create the audio driver (jack).Cannot continue without it."
> I assume both are running as the same user, right?

Yes. I'm logged into the machine as root when trying this.

> Have you tried starting fluidsynth from the command line?
>   fluidsynth -a jack -m alsa_seq soundfont_name

Same result.

> > No further information, no messages from jack.  However if I start
> > fluidsynth as an alsa client rather than jack (as described on the
> > qsynth homepage), it starts fine and I can access it from other program=
> > via alsa.
> >=20
> > Clearly there's something wrong with my jack setup.  Suggestions?
> Do any other jack programs work?
> Freqtweak, for=20
I just installed freqtweak to try.  It connects fine.

Peter Howard
Jabber Id: pjhacnau@12jabber.com
AIM Id: pjhacnau

Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part

Version: GnuPG v1.2.2 (GNU/Linux)