[PlanetCCRMA] *Solved Again* was: Self-configuring system Was:*Solved* Midisport8x8/s Was:Chasing my tail with ALSA

Michael mikes@tbc.net
Wed Feb 18 14:06:01 2004

Nice subject line, eh?


Thanks once again to all who helped, it looks like the problem indeed is 
firmware loading. It's tested and working for now! :-)

Strangely enough, when I first started working on this problem a few 
days ago, the Sourceforge project: http://usb-midi-fw.sourceforge.net/ 
was only up to version .2, and the required driver needed to make the 
Midisport 8x8/s wasn't available anywhere in the Internet world (yep, 
USA, UK, Russia, China... just to name a few countries I tried). The 
Sourceforge project has now been update to version .3, and includes a 
way to incorporate the "newer" driver that M-Audio uses, usb88ldr.sys. 
All you gotta do is extract the driver, and make install as root, and 
the usb-hotplug picks up the Midisport 8x8/s automatically. Cool!

One small insignificant problem I saw in the Alsa Patchbay was that the 
ports were numbered 0-8. Well... thats a total of 9 ports. I haven't 
checked it yet, but I'm wondering if the the "ninth" port isn't the /s 
or SMPTE on the Midisport 8x8/s? I'll check as I get more time....

O.K. gotta run... as time is something I seem to run out of frequently ;-)

Thanks again for the help!
-Mike :-)+<