[PlanetCCRMA] pcm error

thomas gorbach thomas.gorbach@t0.or.at
Mon Feb 16 01:19:02 2004

Fernando Pablo Lopez-Lezcano schrieb:

 > I don't know if the hdspconf has support for all RME cards, most
 > probably yours does not need it. Any other RME users can comment?
 > If I understand correctly you are getting pd to work with the RME (ie:
 > you get sound output from the RME card), then only thing not working is
 > the hdspconf utility, right?

I do the following to get pd working with rme card:

jackstart -R -d alsa -d hw -r 44100
as root or user and rme is working. pd in real time mod is only possible 
  as root.

Yes thats right hdspconf is not working.

the other problem i did not find until now is midi.
if i start pd i have no midi:

pd output:

device -1: tried /dev/midi-01 READ/WRITE; returned -1
device -1: tried /dev/midi-1 READ/WRITE; returned -1
device -1: tried /dev/midi-01 READONLY; returned -1
device -1: tried /dev/midi-1 READONLY; returned -1
couldn't open MIDI input device -1
device -1: tried /dev/midi-01 WRITEONLY; returned -1
device -1: tried /dev/midi-1 WRITEONLY; returned -1
couldn't open MIDI output device -1
opened 0 MIDI input device(s) and 0 MIDI output device(s).

I am using midi over SB sound card. I tried to do alsaconf for the SB 
card, but it is not possible configuring two cards with alsaconf.

I did not have the time to follow the thread with midi at the list but i 
will do this the next days.

Anyway i want to thank very much about the work you did with CCRMA. It's 
a big help for me


 > -- Fernando