[PlanetCCRMA] terminatorX help

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Fri Feb 6 11:10:02 2004

> I just installed Planet ccrma using apt-get install
> planetccrma-audiovideoapps on Fedora Core 1 and have done apt-get
> upgrade so kernel is 2.4.24-1.ll.rhfc1.ccrma.

I presume then that alsa is installed and configured and running, right?

> When I try to run terminatorX (as root) I get the following.

You don't need to run as root. 

> I tried chmod u+s but it makes no difference. I have tried both jackd
> -d alsa and jackstart


> [root@neptune root]# terminatorX 
> terminatorX Release 3.81 - Copyright (C) 1999-2003 by Alexander K?nig 
> terminatorX comes with ABSOLUTELY NO WARRANTY - for details read the
> license. 
> warning: failed to load external entity "/root/.terminatorXrc" 
> tX: err: Error parsing terminatorXrc. 
> tX: Failed loading terminatorXrc - trying to load old binary rc. 
> * tX_error: This binary doesn't support running suid-root. 
> * tX_error: Reconfigure with --enable-capabilities or
> --enable-suidroot if you really want that.
> I welcome any help.

As a non-root user start Jack:
  jackstart -R -d alsa -d hw

That will tie up your terminal. 
>From another terminal type:

It should start and recognize the jack server (and autoconnect its
output to your soundcard). I just tried it and it also prints some
messages at the beginning that seem to imply that the engine is not
running with realtime priority. But it seems to work anyway (the jack
audio thread will be given realtime priority by jack). 

-- Fernando