[PlanetCCRMA] Re: Re:UPDATE insmod errors - rme hammerfall multiface UPDATE

rob canning rscanning@eircom.net
Fri Feb 6 04:07:02 2004

hi fernando, thomas, list,

thanks very much for your help, i feel like i may be getting close now but am still having problems...

i did an apt get install on the new kernel set it asd default with GRUB

when i do alsaconf i no longer get the insmod errrors but i do still get:

[root@localhost robcanning]# /usr/sbin/alsaconf
/usr/sbin/alsaconf: line 120: modinfo: command not found
/usr/sbin/alsaconf: line 127: modinfo: command not found
/usr/sbin/alsaconf: line 135: modinfo: command not found

when i start alsasound
[robcanning@localhost robcanning]$ /etc/rc.d/init.d/alsasound start
ALSA driver already running
Sound driver snd-hdsp is already loaded

when i start alsamixer
 Card: Intel ICH5                                                             ││ Chip: Analog Devices AD1985                                                  ││ Item: Master   

and with the -c 1 argument
[robcanning@localhost robcanning]$ /usr/bin/alsamixer -c 1
No mixer elems found

my modules.conf file looks like this (i have commented out the oss stuff):

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.1 ---
alias char-major-116 snd
alias char-major-14 soundcore
#alias sound-service-0-0 snd-mixer-oss
#alias sound-service-0-1 snd-seq-oss
#alias sound-service-0-3 snd-pcm-oss
#alias sound-service-0-8 snd-seq-oss
#alias sound-service-0-12 snd-pcm-oss
alias snd-card-0ntitlntitled 1ntitled 1ed 1 snd-hdsp
alias sound-slot-0 snd-intel8x0
# --- END: Generated by ALSACONF, do not edit. ---
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
alias sound-slot-1 snd-hdsp
post-install sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
# -- Keep modules from being autocleaned
add options -k snd-card-0

when i run the audio software pd the Hamerfall is listed in its audio devices but when i change to it from the default (intel) it crashes with:

input channels = 2, output channels = 2
alsa: changing output device to agree with input device
device name hw:1; channels in 2, out 2
audio buffer set to 50
ALSA lib pcm_hw.c:1055:(snd_pcm_hw_open) open /dev/snd/pcmC1D0c failed: No such
snd_pcm_open (input): No such device
ALSA lib pcm_hw.c:1055:(snd_pcm_hw_open) open /dev/snd/pcmC1D0p failed: No such
snd_pcm_open (output): No such device
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Bad file
audio I/O stuck... closing audio
ALSA lib pcm_hw.c:751:(snd_pcm_hw_close) close failed
: Bad file descriptor
snd_pcm_close (input): Bad file descriptor
Segmentation fault
[robcanning@localhost robcanning]$ pd_gui: pd process exited

when i do a dmesg i see the lines
ALSA ../../alsa-kernel/pci/rme9652/hdsp.c:5054: card initialization pending : waiting for firmware
PCI: Setting latency timer of device 00:1f.5 to 64
intel8x0: clocking to 48000

the red Host light is permanantly on on the front of the card - it was never like this with a pcmcia card on windows - should that light turn off on linux with a pci card?

thanks again,