[PlanetCCRMA] Error Installing The 'Core' CD Image underFedoraCore-1

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Tue Apr 6 08:41:02 2004

> The alsa package (or any planet-related package) have not been installed
> in this machine, so when I try the query command:
>   rpm -q -a | grep ^alsa
> I just get a new prompt!

Means you don't have alsa installed (I thought there may be a conflict
with a previously installed version). 

> Anyway I forgot to mention that I tried to 'manually' install (with rpm)
> some of the packages from the folders on the CD and always get some
> 'unmet dependencies' messages that I tried to resolver recursively to no
> avail.
> With respect to the alsa-tools the message i get is:
> "
> [root@localhost kasti]# apt-get install alsa-tools
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> Since you only requested a single operation it is extremely likely that
> the package is simply not installable and a bug report against
> that package should be filed.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
>   alsa-tools: Depends: libfltk.so.1.1 but it is not installable
> E: Broken packages

Ok, this is it. You should have at least two cdroms, one for the Core
(kernel and alsa) and another for the applications. You should feed both
to "apt-cdrom add" before starting the install. Alsa-tools needs fltk,
which is on the other cdrom. If you installed Fedora from the
"planetized" Fedora Core cdroms then you should feed those to "apt-cdrom
add" as well before starting, otherwise you will also get missing
dependencies unless you have done a full install of Fedora Core
(installed all packages). 

-- Fernando