[PlanetCCRMA] Problems with the new kernel SOLVED

Sampo Savolainen v2@iki.fi
Sat Sep 27 13:07:00 2003

On Sat, 2003-09-27 at 21:57, Fernando Pablo Lopez-Lezcano wrote:
> > I tested mounting a fs with the --ro parameter, which I've never seen
> > before in my life and it really worked, it really mounted the fs. 
> Meaning it mounted "ro" even though it has a "-o rw" as well?

I wrote that in quite a hurry. :) 

Yes, using the command "mount -o rw --ro" mounts a filesystem read-only,
when I use it from a running system. From the initrd, it apparently
mounts the fs read-write.

> > Now what I can't figure out is why didn't it mount the fs read-only for me
> > and why it mounts read-only for everyone else?
> What version of mkinitrd do you have? On RedHat 9 I get 
> mkinitrd-3.4.42-1. Version of mount? (mount-2.11y-9) I would imagine it
> could be a problem with mkinitrd (seems to be adding a "rw" parameter to
> the mount line) or mount (does not behave as expected - but it _does_
> when you execute it outside of the mkinitrd script?). Very weird. 
> I'll see if I can check what I have in my redhat 9 systems...

I have mkinitrd-3.4.42-1.

I don't think that makes any difference. I didn't build the kernel, I
just installed the binary one with apt-get upgrade.

And as I said earlier, I modified the image by mounting it, making the
changes, and umounting it. I didn't use mkinitrd for that.

(If I forgot to mention it earlier, I'm running RH9.)

> > But, anyways. Everything seems to be in order and I have a kick-ass
> > kernel and ready to do some recording!
> > 
> > Thanks for your great work on these packages Fernando!
> Sure! Glad the system is up and running...

With the new kernel I can enable ACPI, and I think my problems running X
with DRI enabled are also gone. 

One problem has emerged. After running apt-get update, apt-get upgrade
reports this error:

Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  alsa-kernel-2.4.20-20.1.caps.rh90: Depends: kernel-version (=
                                     Depends: kernel-version-arch (=
  planetccrma-core-redhat: Depends: kernel-version-arch (=
E: Unmet dependencies. Try using -f.

I guess this could have been triggered by me not running apt-get update
before I did the dist-upgrade (I had updated a few days before that,

Any idea what I should do? I don't use the 2.4.20 kernel, so I could
just remove those packages?

 Sampo Savolainen