[PlanetCCRMA] locale breaking redhat-config-services

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Mon Sep 1 12:12:01 2003

> after an upgrade, well I don't know when exactly, redhat-config-services stopped 
> functionning. It gives now this error message, and this is on my two
> redhat+planet ccrma machines:
> ------------------------
> [root@localhost dany]# redhat-config-services
> /etc/init.d/Services [Errno 2] Aucun fichier ou répertoire de ce type: '/etc/init.d/Services'
> ------------------------
> meaning that /etc/init.d/Services doesn't exist, indeed.

So I tried to see if /etc/init.d/Services was referenced in the files
that are part of redhat-config-services package, so I did this:

  rpm -q -l redhat-config-services|xargs grep "/etc/init.d/Services"

All I get is a bunch of "No such file or directory" error for the files
in the locale directory, for example:

grep: /usr/share/locale/fr/LC_MESSAGES/redhat-config-services.mo: No
such file or directory

So I said, well, something erased those files! But:
  rpm -V redhat-config-services
does not report an error... so the package is fine. But the files are
missing. Looks like a packaging problem to me...

> so I wanted to  post this error message... in english. I changed the locale LANG
> to C and now redhat-config-services launched without any problem... So
> the error has a relation with the french locale (and with others
> locales too maybe).
> Pablo, is it the right place to report this or is it totally redhat.com related

It looks to me like it is RedHat related. But you say it was working
before installing Planet CCRMA. I don't think I have touched any
packages that deal with locales (except for those that _use_ them). 

BUT, I just tried uninstalling and reinstalling redhat-config-services
and now the files _are_ there (on RedHat 8.0). Uh??? Could you try
reinstalling the package?

-- Fernando "scratching his head"...