[PlanetCCRMA] problems to update muse (and others) ...

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Mon Oct 27 10:54:02 2003

> here is my problem (longer story to tell everything):
> i had a redhat 7.3. i updated to 9.0 (from cd) and tried to install
> (with your cd-iso) audio-apps (which worked not perfect (some error
> messages i forgot ), but everything i needed was ok).
> i did not have internet duiring that time...
> now i have internet and tried to update with apt-get. i had a lot of
> problems with that, because apt-get (and rpm) could not update or remove
> lilypond (after updating i always had 2 versions).
> i solved this problem (with the help of a friend) with
> rpm -e --noscripts --notriggers lilypond
> and after that i could update almost everything.

When something like that happens again please search the Changelog for
the package name. This particular problem was due to a very old bug in
the 7.3 scripts of the lilypond package (a typo I made) and a workaround
was described when I updated the package to a newer version. 

> this is what i get now (its a german version i tried to write the
> translation behind the original:
> [root@localhost rpm]# apt-get upgrade
> Lese Paketlisten... Fertig	
> (read package-list...ready)
> Erzeuge Abhängigkeitsbaum... Fertig
> (build up dependence-tree...ready)
> Die folgenden Pakete sind zurückgehalten worden
> (the following packages are kept back)
>   ecamegapedal ecasound libswami muse soundtracker
> 0 Pakete upgegradet, 0 neu installiert, 0 entfernt und 5 nicht
> upgegradet.
> i work with muse, so i want to update it. when i try to do it with rpm,
> i get the following message:
> [root@localhost rpm]# rpm -Uvh muse-0.6.1-2.rh90.i386.rpm
> Fehler: Failed dependencies:
>         libsndfile.so.1(libsndfile.so.1.0) is needed by
> muse-0.6.1-2.rh90
> and the last info i can give at the moment is this:
> [root@localhost rpm]# rpm -q libsndfile
> libsndfile-1.0.5-1
> what do/did i do wrong ? or what can i do now ?

You did not do anything wrong. The problem happens because the
libsndfile package still is not "RedHat version" tagged and so is not
going to be upgraded automatically to the version that the redhat 9
packages need. 

To fix this just force erase the package:
  rpm -e --nodeps libsndfile
and then use apt in "fix mode" to install the correct one:
  apt-get -f install

There may be other instances of packages you will need to upgrade

-- Fernando