[PlanetCCRMA] More ALSA driver building, HDSP9652 patch

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Fri Oct 3 11:04:05 2003

> so I tried applying patch and building alsa-driver again and again got:
> Patch #7 (hdsp9652.patch):
> + patch -p1 -s
> missing header for unified diff at line 3 of patch
> The text leading up to this was:
> --------------------------
> |--- hdsp.c.0.9.6       2003-07-18 12:04:59.000000000 +0200
> |+++ hdsp.c     2003-08-16 16:14:18.000000000 +0200

The spec file applies the patch (that's what the %patchXXX macro does)
while cd'ed to the package main directory (ie: alsa-driver-0.9.x in our
case). There is no file named hdsp.c there and that's why patching
fails, so you have to edit the patch so include the whole path to it, as
in this example:

--- alsa-driver/alsa-kernel/pci/rme9652/hdsp.c.0.9.6	2003-07-18
12:04:59.000000000 +0200
+++ alsa-driver/alsa-kernel/pci/rme9652/hdsp.c	2003-08-16
16:14:18.000000000 +0200

[you also have to edit out one chunk as the 0x32 device id is part of
current alsa, otherwise the patch process fails on that chunk]

I tried to build both on 0.9.6-2.cvs and 0.9.7-1.cvs (as yet unreleased)
and the build fails, the patch does not appear to be compatible with
either release. This is where it fails:

-D__BOOT_KERNEL_SMP=1 -I/usr/src/redhat/BUILD/alsa-driver-0.9.6/include 
-I/usr/src/linux-2.4.22-6.ll.rh90/include -O2
-mpreferred-stack-boundary=2 -march=i686 -D__SMP__ -DCONFIG_SMP -DLINUX
-Wall -Wstrict-prototypes -fomit-frame-pointer -Wno-trigraphs -O2
-fno-strict-aliasing -fno-common -pipe -DALSA_BUILD 
-DKBUILD_BASENAME=trident_synth   -c -o trident_synth.o trident_synth.c
../../alsa-kernel/pci/rme9652/hdsp.c:3855: structure has no member named
../../alsa-kernel/pci/rme9652/hdsp.c:3855: structure has no member named
../../alsa-kernel/pci/rme9652/hdsp.c:3857: structure has no member named
../../alsa-kernel/pci/rme9652/hdsp.c:3857: structure has no member named
make[2]: *** [hdsp.o] Error 1

-- Fernando